Login  Sign up

Cant record encrypted RTMP stream on Windows 10

I used to record RTMP encrypted stream with Jaksta 4.x.

After updating to Windows 10 when I start Jaksta 4 I get error “Could not load driver JakNDis” so I updated to Jaksta Media Recorder 6. But now I can’t make it record my RTMP streams.

Setting -> Internet Download -> Advanced -> RTMP I have turned on Always record RTPM streams. I have checked that port 1935 is monitored for RTPM protocol.

For detection I am using WinPcap (also Network monitor was installed I am not allowed to select it?) and I have tried all network interfaces without success.

When I listen to the encrypted RTMP stream in my browser Jaksta does not detect it.

As all this did not make sense I have tried Media recorder 6 on a Windows 8.1 machine and here all works perfectly. So problem seems to be related to Windows 10

Is there a way to have Media recorder 6 works on RTPM stream on Windows 10 machine?


When I was looking at the network interface reported by WinPcap I had 4 Microsoft entries that did not make too much sense. So I did search on the net and found out that there is a new WinPcap for Windows 10 (see http://www.win10pcap.org/) that works flawlessly with Windows 10.

I have therefore uninstalled WinPcap 4.1.2 and installed Win10PCap 10.1-5001 (bin compatible with WinPcal DLL).

In Setting -> Internet Download I select WinPcap monitor and in Network Interface monitored by WinPcap I now have coherent entries with my system. I then selected the correct network for my system and … it works :)

I thought other people having problem with Windows 10 might be interested by this solution.

I will also advice that you change WinPcap to Win10Pcap in your distribution.

The Winpcap distributed with our products is 4.1.3, and is the latest version of winpcap (http://www.winpcap.org/).  

I have no idea who is behind Win10PCap 10.1-5001, but it is not from the official winpcap site so be careful.

Winpcap 4.1.3 works perfectly well with JMR on windows 10.  

Because you upgraded to windows 10 and because you had 4.1.2 installed there is probably alot of issues that could of happened. 4.1.2 did not work on windows 8 for example - hence why 4.1.3 was released by winpcap - so Im sure there would also be issues with 4.1.2 on windows 10. 

Installing 4.1.3 which is distributed with JMR and rebooting probably would have sorted your issue.

Be careful using winpcap10.  Its not from the official winpcap site.  Im not saying there is an issue with it - just saying its not from the official site.

If you want to sort out your Jaksta Network Monitor issue following your upgrade to Windows 10 - You had version 4 installed which is many years old now and the windows 10 upgrade has stuffed it.  The following *normally* fixes it.

1. Install the Jaksta Network Monitor in JMR 6 (its in the install directory).

2. Reboot.

3. Now uninstall it - Jaksta Network Monitor - using Add/Remove programs.

4. Reboot again

5. Now reinstall it - if you want to use it, and you should be good to go.  

Unless your capturing from VPN connection, there is no reason to use the Jaksta Network Monitor - Winpcap takes up a lot less of your machines resources.  If you do want to capture from an NDIS5/6 VPN connection then that is when you require the JNM.


Many thanks for your information.

Based on your input I have removed Win10PCap and installed WinPCap 4.1.3 and this indeed seems to solve the problem even though the WinPcap reports the Microsoft network interface 4 times.

It is probably a better idea than using Win10Pcap even if it is coming from a university in Japan

By the way it would be nice if your installer could check the version of installed WinPcap and propose to upgrade if version is inferior to 4.1.3 because 4.1.2 did work for me on Windows 8.1 but not on Windows 10

Thanks agaain

I am reopening the problem because it does not work on another system.

As mentioned above I have been able to make it work on my laptop.

I have now installed Windows 10 on my main system.

This is a fresh installation from scratch.

I have installed Jaksta Media Recorder along with WinPcap 4.1.3 you provide.

When I try to record the encrypted stream nothing happen.

I can see that the player is connecting on port 1935 (the default) but Jaksta does not see it?

I have rebooted several times without success.

Any idea what when wrong?

As above in advance settings RTMP the "always record" is turned on

I have tried to deinstall and reinstall both Jaksta and WinPcap without success :(

Please post your debug logs and details of the site.


Here is the log


is the site your trying to capture from hos.com?

Your logs show monitoring started after the RTMP connection was created.  Start monitoring before or refresh the page (hold the shift key down)

Yes the site is hos.com

I am aware that the monitoring should be on before going to the site. May be I did not do it when logging information.

Here is a new log where monitoring was turned on before going to hos.com page + I did a refresh of the page as it did not start to record correctly.

What is strange is that I have another machine (a laptop) also running Windows 10 where the recording works fine.


May be a monitoring on the working machine can help

Note that on this machine port 443 is used (I have added it in the port config).

But with another browser on the same machine it uses 1935 and works in both cases


Those last logs show a successful recording happening?  You have always record rtmp on in the settings, so it will record instead of downloading.  This means you have to keep playing it in your browser.  

Yes the last log was done on the "working machine".

From what I understand the rtmp flux is encrypted and therefore cannot be downloaded. The player in the Web browser must be decrypting on the fly (?) and therefore the only way to record is to set JMR in "always record rtmp" and to play the complete show in the browser while JMR record.

What is not working in the second machine is the fact that JMR does not seems to see the rtmp flux.

The  way I record is the following :

- I set JMR to always record

- I set JMR to AUTO

- I start the browser at hos.com -- the browser indicate connecting on port 1935 (or sometimes on port 443 depending on browser)

- I click play in the browser and normally at this time JMR should start recording

Its not encrypted RTMP (rtmpe), just good old RTMP. 

hos.com just doesnt allow multiple connections.  

Your better off adding hos.com as a secure site than switching on always record.  That way it will only record hos.com and not all the RTMP connections you come across.

Settings > Internet Downloads > Advanced button

Site Specific

Add hos.com and the site url and flv as file extension and click add.

Then switch off Always record RTMP.

1935 is the normal port for RTMP. 443 is being used as a fall back port as 1935 can be blocked by firewalls, where 443 is normally always open as its the https default port.

Please provide debug logs from the machine where recording is not happening.


Login or Signup to post a comment