Login  Sign up

Cant record encrypted RTMP stream on Windows 10

I used to record RTMP encrypted stream with Jaksta 4.x.

After updating to Windows 10 when I start Jaksta 4 I get error “Could not load driver JakNDis” so I updated to Jaksta Media Recorder 6. But now I can’t make it record my RTMP streams.

Setting -> Internet Download -> Advanced -> RTMP I have turned on Always record RTPM streams. I have checked that port 1935 is monitored for RTPM protocol.

For detection I am using WinPcap (also Network monitor was installed I am not allowed to select it?) and I have tried all network interfaces without success.

When I listen to the encrypted RTMP stream in my browser Jaksta does not detect it.

As all this did not make sense I have tried Media recorder 6 on a Windows 8.1 machine and here all works perfectly. So problem seems to be related to Windows 10

Is there a way to have Media recorder 6 works on RTPM stream on Windows 10 machine?


Hum may be I am wrong with encryption. As a guest you’re only entitled to record 30 seconds of the week’s show and you can listen to sample’s shows. As a registered user you can listen to the full shown on Sunday (this is may be where it is encrypted? But not sure).

I have been recording the show since 2009 see http://stream-recorder.com/forum/record-stream-heart-space-t4707.html?amp;

For background info please look at http://stream-recorder.com/forum/hos-hearts-space-rmc-error-internal-error-t4617.html?t=4617 where it was recommended to use Jaksta and it has been working flawlessly since. Until I moved to Windows 10. :(

On my laptop (running Win 10 Home) after updating to WinPCap to 4.1.3 JMR now works without problem (this is the last dump I have sent) following the procedure I have described.

On my desktop (running Win 10 Pro) I can’t make it work (this is the dump before last). JMR just do not see the stream.

I have tried what you asked me to do but again nothing happen on my desktop. Same problem JMR does not see the stream.

I did try what you suggested on my Laptop and it works great. The stream is not downloaded but recorded as specified (perfect :) )

FYI one of the specificity of my desktop is that the mainboard has two Ethernet connections (this is an Asus P8P67 board). The Ethernet cable is connected to one entry and I have selected this entry in settings->Internet Download == WinPcap Monitor -> Network I/F monitored I select the right Ethernet i/f.

Could that be related to the problem?

Looking at the beginning of the jmrp.exe.log I can see that WinPcap is correctly monitoring the Intel(R) 82579V Gigabit Network Connection: ???


Attached is the log with the setting you requested.



Your logs say that  "Realtek PCIe GBE Family Controller" is selected for winpcap to monitor (\Device\NPF_{AC652B0C-8EC7-4AA3-A5AA-3341A0A67C0F}).

They show no ipv4 network traffic on that interface.  

Could it be that you have just selected the wrong one?

If not do you have IPv4 enabled and configured on that interface?  Check the connection properties for the interface.  

Sorry my mistake on the last dump. You are right was set to the wrong IF. But unfortunately not the problem 

What I did to further test:

- Reinstalled latest version of WinPcap 4.1.3

- Tested using the Realtek network chip (not better than Intel for this problem)

- Installed latest drivers from Intel for network chip (https://downloadcenter.intel.com/fr/download/25016/Pilote-r-seau-pour-Windows-10)

- Tested WinPcap with WinDump

- Installed WireShark 1.12.7 to test WinPcap (records fine).

Unfortunately nothing fixes the problem. This drive me crazy! There is no good reason why it is working on my Laptop and not on my desktop. Currently the OS is very clean because I reinstalled from scratch only few days ago so no pollution!

For recording I used your recommended settings (adding hos.com to site specific and not setting record RTPM).

With this settings I did:

- Starts JMR + µDebug

- starts Wireshark recording

- Goto hos.com in Chrome for a 30 second sample.

- Stops Wireshark and JMR

I am not enough knowledgeable about network protocol to follow all the transactions but I can see the NetStream.Play.Sart message followed by NetStream.Data.Start' on Rtmp then later player stop.

I do not know if you have Wireshark but just in case I have also attached the WS dump along with the JMR dump

Login or Signup to post a comment