Login  Sign up

iPlayer problem after update

I'm reposting all of the following from the Mac forum!

17 AUG

I did an update for Jaksta MR this morning and now I cannot get it to record from iPlayer. 

The last time this happened you advised me to do a re-install and clear my browsers cache history. That's what I have just done again and it still won't work.

Help and suggestions, please...

Thanks, BobG

18 AUG

Hello? Have you any suggestions, please?

18 AUG

An update… 

I’ve just done another complete uninstall and re-install.

Then I tried to capture www.bbc.co.uk/programmes/b07m57mz

Good news, I was offered a choice of the various formats available. I chose High and mp4…immediate failure, Complete (with errors) zero size…big sigh.

So I reset my option to High and prompt, then tried again. When offered I selected mp4 1280x720 and…it works!

Please can you advise me as to which options to select to avoid having to make a manual selection every time?


18 AUG

Have yet to record the whole programme... 

21 AUG

Manage to get a complete download...at last, but it's a pain having to try out all the options on offer. What happened to being able to specify high / mp4 and let Jaksta do the rest?

22 AUG

Ben made some suggestions that I followed.

23 AUG

Hello Ben

I've just tried the first of your two suggestions but opting in to the BBC HTML5 Player. Then I tried to download.


     First attempt High / mp4 : Complete (Errors)

     Second attempt High / Any: Complete (Errors) 

    Third go Prompt / Prompt: started but Complete after 5 mins of 1 hour programme.


Where's the log file? You said "You can find it by clicking the Find Log File button in the Preferences." Preferences...where is Preferences? What I did find was a Send Logs button (paper aeroplane) under Support, I hope that's what you're after...please see attached.


Now for your second suggestion!


Regards, Bob

24 AUG

Ben posts to tell me I'm in the wrong part of the support site and suggests I post over here!

Frustration is setting in...BobG

I've received an email response from HTH, but it doesn't seem to have appeared in this thread.

Firstly he told me: "iPlayer has a new dash protocol that is now appearing first in the list which we dont support yet and is being selected when you set an automatic quality/format. There are still plenty of HLS protocol streams for you to download though as you have identified. Just select any that dont say Dash in the stream."  That worked!

Then he advised me "If the HLS stream is being cut off early its most probably and ffmpeg issue. We have a new version coming out shortly which updates ffmpeg to the latest version.And so I should overwrite the version of ffmpeg.exe on my PC with the version from the "the latest static 32 build". That worked, too!

Thank you HTH

Regards, Bob

PS I'll leave you to supply (or not) a link to the site for downloading the new version of ffmpeg.exe. RG

Sorry - I deleted it soon after posting it as I realized that the new version of ffmpeg I was suggesting wont work for some downloads (like youtube) that require muxing until the new release is out.  This is because the new ffmpeg no longer supports libvo_aacenc which is what the old muxer uses. Best to wait until the new version is out, or you might need to swap ffmpeg back and forth between versions.

New version hopefully tomorrow!

HTH means "Hope that Helps" ;)

That explains a lot...but not what CRS stands for!

Looking forward to the update. Let's hope that it does what we want it to do.

All the best,


I've just upgraded to version and tried to download from www.bbc.co.uk/programmes/b00cbpy7...without success.

I tried Prompt / Prompt and High / mp4...both ended in Complete (Errors) and no download.

The ffmpeg.exe file is dated 25 August and, at 34,625 kb, is intermediate in size between the old version and the latest stable version I downloaded (see above).

Off to try something from TV...


TV download OK using Prompt / Prompt. High / mp4 didn't work, so version is operating just as did the old version with the downloaded stable version of ffmpeg.exe.

That is TV downloads but not radio from iPlayer.

Zip file of logs is attached.

Hopefully you'll be able to get this sorted. Thanks,



Thanks. On to it.

Extraction engine just updated...still no luck with www.bbc.co.uk/programmes/b00cbpy7 unless I let it play and capture it live.

Different thing.  It requires support for downloading the BBC iplayer Dash protocol to be added to the core as mentioned earlier.  Will be released later today as 1.44.

Many thanks for! It works...all all respects. I'm back to High / Any and can download both radio and TV using URLs from iPlayer.

Until the next time...but I hope not.

All the best,


I spoke too soon!

A TV download from www.bbc.co.uk/programmes/b07tj8vp had started and promised a 1280x720 resolution. What I hadn't noticed was that it expected a file of only 52 Mb..and once it got to 100% it reported Complete (Errors). Log file attached.

I'll see if it'll work with another choice of options. 


OK...I tried High / mp4 without success, but High / Prompt offered me two DASH options, mp3 & mp4, and it downloaded (H264, 1280x720, 4980 kbs, 50 fps) OK.

Try this one which should work for High/MP4 on that url:  http://downloads.jaksta.com/release/jak6/JMR6/

Thanks...I thought was going to work. It started to download and identified a file size of over 2 Gb, but didn't report anything for the duration. I watched it to over 40% completion, but twice  it has aborted to Complete (Errors). Log file attached...


Yep its big but downloads fine here.  I use unblock-us to bypass geo restrictions.

Your logs show "The remote server returned an error: (502) Bad Gateway" errors. This is the proxy or vpn your using dropping out.

You wont get a duration displayed for BBC dash protocol downloads until everything is downloaded and the audio and video are muxed.   

Login or Signup to post a comment