Welcome
Login  Sign up

Cannot Record Jasmin RTMP

I used to record RTMP streams from livejasmin.com free chat and the private shows I'd paid for. A few months ago, livejasmin.com was shut down, leaving only the newer jasmin.com and new.livejasmin.com sites. I've only recently attempted to record a private at jasmin.com and discovered that Jaksta (at least with my settings) is unable to do so.


Jaksta records a second of a 'private' RTMP stream before 'Tagging' and 'Completing' the capture (I've added jasmin,com/flv to Site Specific Settings). Attempting to download a private in Jaksta terminates the show before it begins (presumably only a single request for a private stream is allowed).


On any of the pages listing performers, the exact same behaviour is exhibited when accessing free chat by hovering over a performer's thumbnail. Usually only one second is recorded (on extremely rare occasions, indefinite recording). If record RTMP is off, Jaksta is able to download free chat for as long as one hovers over the thumbnail (why does the download stop?). Thumbnails also provide an identical HTTPS stream of free chat (I now have Monitor HTTPS/SSL off).


I don't know if the two occurrences are technically identical because I don't know what to look for in the jmrp.exe.log files. I wont upload any debug logs right away in case you want me to use certain Jaksta settings or include network traces in logs etc (also, mainly using Chrome, can use Edge).


Thank you.


"By the way, when downloading RTMP from a thumbnail, the download terminates when the cursor is merely moved away, not over another performer (it's not a case of download limitations). That's why I'm curious as to why it doesn't download indefinitely."


> This is their site closing the connection.  Make sense as its a preview of the cam.  Nothing can be done here as their server closes the connection.


As I said in my reply, I can't test private chats. 


If you would like me to look at your debug logs then please ensure Settings > Internet Downloads > Advanced > RTMP > Always record RTMP streams (instead of downloading) is on and then follow the instructions here: https://support.jaksta.com/discussions/topics/6000009063

'Always record RTMP streams' and AUTO have always been on at start (and recently 'Monitor HTTPS/SSL' off) alongside default settings.


Tried and was refused entry to two private shows (said they had gone offline which was untrue). Double checked that 'Always record RTMP streams' was on and other settings.

zip

I wondered whether updating Jaksta affected my settings so I reset it and turned 'Always record RTMP streams' back on again (as-well as Monitor HTTPS/SSL' off) and have since been allowed entry into a private show. It recorded two RTMP streams from a single show, both under a second long.



zip

I've experimented with settings and having just 'Automatically fix RTMP live streams and those without a duration' off produces near perfect captures. The only error being duration (videos are shorter than stated) but 'Fix FLV/Fix Duration' can correct that.


Having Rebase RTMP timestamps to zero' off as-well sometimes produces videos with grossly incorrect durations (by minutes) that 'Fix FLV' cannot repair. Not recommend for anyone reading this.


Thanks for spending your time on this. I didn't try many private shows during recent testing but hopefully results are indicative of future attempts. Obviously I'll let you know if something crops up. Thanks again,

"This is their site closing the connection. Make sense as its a preview of the cam. Nothing can be done here as their server closes the connection."

 

I see, thanks. What threw me was sometimes RTMP previews would continue to download until 'Stopped Manually' in Jaksta but I guess they were server side 'anomalies' (as opposed to the one second RTMP recordings being Jaksta's 'error').

 

With 'Always record RTMP streams (instead of downloading)' and Debug Mode on, I twice tried and failed to enter a private. It's as if record didn't work, Jaksta requested second downloads of the stream and I got booted. After adding jasmin.com to Site Specific settings, Jaksta managed to record one second of private. Please see logs attached.

zip

Adding jasmin.com to Site Specific settings wont do anything as mentioned previously as jasmin.com uses IP addresses in their urls not domain names.


So this is what I see in your logs happening:


At 19:16:10: Model KatyaFox, secure stream with AlwaysRecordRtmp set to on.  


Stream is from rtmp://109.71.162.194:1935/tvchannel<break>katyafoxxx.free.21597744d4cfb88aa3c3c43e84f73215, 


Recording starts and contrinues for about 4 seconds (~784 KB).  The server then closes the connection, and recording stops.


At 19:16:18, You then play it with VLC and then delete the file to your recycle bin.


At 19:17:02 a new connection for KatyaFox is created this time to


rtmp://109.71.162.27/memberChat/jasminKatyaFoxxx3b730056889b6ebbc077f781536a9ffa


Looks like private session


Afew seconds later at 19:17:14,225 a closeConnection message from the server is then received and the connection is closed at the network level by the server.


Another connection is made this time to


rtmp://109.71.162.194:1935/tvchannel<break>katyafoxxx.free.21597744d4cfb88aa3c3c43e84f73215


I would assume is the free channel again


Recording starts again at 19:17:14,788 and continues to 19:17:22,694 (1.41 MB)


The server then sends a network fin and reset, so the recording is closed.


You then play the file with vlc @ 19:17:25,224, and delete it at 19:17:29,248


Another rtmp connection is then started at 19:17:33,351


This one is for rtmp://109.71.162.27/memberChat/jasminKatyaFoxxx3b730056889b6ebbc077f781536a9ffa<break>privstreams/clonedPrivateLiveStream


Looks like private again


Recording then starts again at 19:17:50,694 till 19:17:53,721 (1 MB) when a NetStream.Play.Stop for privstreams/clonedPrivateLiveStream is received from the server and the recording is closed.


Data continues to arrive up until you collect the logs @ 19:18:05,186 bu the recording is closed so ignored.


Not sure why a server would send a NetStream.Play.Stop when infact it is not stopping.  You can see the packet in the log file jmrp.exe.log.1 processed between 19:17:53,721 and 19:17:53,726



































Thanks. Should be really close now hopefully.


http://jaksta.s3.amazonaws.com/release/jak6/JMR6/6.0.1.57/JMR6-6.0.1.57.exe


Same gig - Ensure Always record is on, switch AUTO on and then go to models page and into private.

 

Send through debug logs.

Tried two privates with some success. The first private yielded two captures, the first being a successful recording, the second, a capture of under a second (similar to previous failures). The second private resulted in a capture with a fuzzy image and an echo (as if two streams merged) plus another entry with 'Errors' (13 bytes).

zip

Hi I just wanted to check the status of this as I was wondering whether one could use Jaksta for jasmin.com private streams. Did you get the fix in place / is it working in 2.0? Thanks!

There are two streams within the same connection which is unusual - never seen it in the 6 years. The first goes for about a second and then stops.  Because the first stream stops the second stream was never processed.  That is what we are trying to implement here - support for capturing that second stream.


So the first stream stopping is what we expect.  The second should keep recording until you stop it.  


That is what your latest logs appear to show. (looks like you closed the browser) after about 12 seconds.  No sign of any error in the logs and second stream looks to be recorded fine as we would expect.


You may want to try switching off Auto fixing and rebasing in the Settings > Internet Downloads > RTMP for any that are fuzzy.


If still not working, perhaps provide logs for a stream that is fuzzy along with the file.  capture a minute if you can, 12 seconds sometimes isnt log enough for the cam to settle down.







Ok so Ive made some changes to try and support this


http://jaksta.s3.amazonaws.com/release/jak6/JMR6/6.0.1.55/JMR6-6.0.1.55.exe


This probably wont work first time as Im only going off the behaviour in your logs and dont have anything to test it against, so could you please download and install this and then provide your debug logs as you go into a private just as you have done previously.


Thanks.


I can download free channels from jasmin.com here .   Infact I can close the browser tab hosting the model and JMR continues to record.  Please provide debug logs if you can't download a free stream.


blob1478570899542.png


When hovering over a model's thumbnail, the site is opening an RTMP stream, which if monitoring is on will be picked up and downloaded. When you move to another model the previous streams are closed by the server and the new one is opened and the same happens.  This is just how their site works.  JMR is doing what it is supposed to and picking up RTMP streams and downloading them.


I cant test private streams, but the site is streaming rtmp so if a stream closed it is because the server is cutting it off when you go private.  It may be possible to record instead of download.  


There doesn't seem to be any pattern we can use for a site specific recording as they use IP addresses and random paths for their server endpoints so you will need to switch on Always record RTMP.


Settings > Internet Downloads > Advanced > RTMP > Always record RTMP streams (instead of downloading)


blob1478572057157.png


 

HTH





I am using Jaksta for Mac. Can confirm the new livejasmin will not record the private shows.
Login or Signup to post a comment