Login  Sign up

Not a valid FLV file

Hey, I used to be able to capture the video stream but its been a few months since I tried.  Now, the capture starts but gives me an error "Not a valid FLV file" and stops at 13 bytes.  Any hints on how to fix this?  Right clicking says its using JW Player 5.9.2156 and Adobe Flash Player so it should be a good FLV file.

Please provide the url of the page hosting the stream and debug logs as per https://support.jaksta.com/discussions/topics/6000009063


Stream is copy protected and can only be recorded not downloaded.

Looks like there is an issue introduced when we made changes to support Jasmin private shows.  Settings > Internet Downloads > Advanced > RTMP > Automatically record secure streams setting is being ignored.  

Whilst I fix that you should be able to record still by switching on Settings > Internet Downloads > Advanced > RTMP > Always record RTMP Streams (instead of downloading)

Ill get a beta to you later today to try.

Thanks for reporting it. 

Unfortunately, he temp solution (Always record RTMP Streams) isn't working.  It records some of the video but then stops.  I will await the beta.  Thanks.


Stange as it works here fine.  

If RTMP recording is not working on your machine then the auto detect fix wont improve anything as all as that does is automatically switch to recording when a secure stream is detected. 

Please make the following changes and resend your logs as they have been cut off.

1. Copy C:\Program Files (x86)\Jaksta Technologies\Jaksta Media Recorder 6\jmrp.exe.log4net to a location where you can edit it.

2. Open it in notepad or your fav text editor.

3. Change

 <param name="MaxSizeRollBackups" value="5" />


<param name="MaxSizeRollBackups" value="20" />

3. Save and copy it back over the original 

Then start JMR, switch to debug mode and do a recording again.  As soon as recording stops, stop AUTO mode and collect debug logs and attach here.

It seems to stop randomly.  The log is attached for when it stopped at 4.8MB.  A prior try stopped at 51.4MB.  Thanks again for your help.


What version of winpcap are you using?  Look in Control Panel\Programs\Programs and Features.

Can you also please provide debug logs with "Include network trace in debug logs switched on".


WinPcap 4.1.3 9/25/16

New log attached.  Thanks.


Can you try this one please?


You can switch off "Include network trace in debug logs switched on" for these tests, but ensure debug is on so you can collect logs.

Try first without "Always record RTMP Streams (instead of downloading)" on and see if JMR detects its a secure stream and starts recording (instead of trying to download).

If that doesnt work, attach logs here, then turn "Always record RTMP Streams (instead of downloading)" back on and try again. 

If recording terminates prematurely, attach logs here.


Thanks for the new version.

Yes, it auto detects secure stream and starts recording.  However, still having issues with the recording stopping early.

Log reflects stop around 0:10 after start although the clock didn't turn into a check mark till about 8 minutes later.  


Sorry can you turn off "Include network trace in debug logs switched on", and reperformance the test.

Delay would be caused by all the network data being written to the log file, because that is still on.

Tried two different streams.  Both stopped prematurely.


Can you get me debug logs using this one please



Still stopping early :(

Login or Signup to post a comment