Login  Sign up

YouTube Red issues

YouTube Red videos don't seem to download on stream record. It just downloads a promotional video as if an account didn't exist. I understand that Jaksta will open a second stream in order to download if it can, however is there any way to force it to download the stream directly from the browser?

I have tried using the DVR option, but it doesn't seem to download in a good quality, even if I set the video playing in the DVR browser to the highest possible setting.

I think at one point there was an option to just do a screen record with the software, but I can't seem to find that option anymore (or maybe I'm misremembering)

Could you please upload your debug logs for YTR.  


DVR is better than screen recording.  If you are not getting good quality then that will be down to the speed at which your machine can capture.

You could also try switching off the Extraction engine and switching on Auto mode.

Settings > Internet Downloads > Advanced > Extractor and click off the "Enable Video Extraction Engine".

Then switch on AUTO before going to the page hosting the youtube red video you want to download.

I have generated two logs, one with the extraction engine turned on and one with the extraction engine turned off.

With the engine turned on bit it grabs is just the preview while attempting to do a stream download. Log with engine on is Jaksta Media Recorder 6Logs-636232953328443964

With the engine turned off, it simply doesn't grab anything as if nothing were playing. Log with engine off is Jaksta Media Recorder 6Logs-636232953577147007

I noticed that the engine was updated today, and now Jaksta no longer seems to work with Firefox. It brings up a page saying the connection is not trusted. I have attempted to reinstall the certificates via Settings > Advanced > HTTP > Reinstall FireFox HTTPS Monitor, but that hasn't fixed the issue. I verified that the certificates are actually installed in Firefox, but it still does not work. I'm not sure if you want me to submit another topic for this, but I have generated a third log for the Firefox issue. The log for this one is Jaksta Media Recorder 6Logs-636232954148520329.

As far as the quality for DVR is concerned, it is not being limited by hardware or network connection. I can do a screen record with another program with no issues on quality and doing a side by side comparison shows that the file given from a DVR session is fuzzier.


I've added a login capability for the extraction engine which will support youtube red via that capture method in future versions.

Logs 47007 says your engine is still on?  >>>>>> 2017-02-21 17:34:56,058 [5] INFO c4 [(null)] - AsyncProxyManager: 56. ExtractionEngine is enabled and ignore url found - ignoring.  

Can you try again and check correct logs.

Extraction engine has nothing to do with firefox certificates.  Today's update only just happened minutes ago (2017.02.21).  Your logs show you received 2017.02.17.   Logs wont tell us whats wrong with FF unfortunately.  My suggestion would be to delete all the Jaksta certs from firefox, make sure it's closed and then reinstall.  The profile JMR is checking is C:\Users\Justin\AppData\Roaming\Mozilla\FireFox\Profiles.

DVR is effectively screen recording  :).  The DVR is recording from an IE instance.  You would need to make like for like recordings with the other product.  Same video with same bit rate etc from IE to same quality/format.  Jaksta DVR recording settings are on Settings > DVR.  YouTube gives excellent DVR recordings here at the default 29.95.  Of course though its better to download if you can.

I have attached another log with the engine turned off while trying to get a stream capture from Chrome. As with the first time, with the engine turned off nothing was started in the download queue.

At what point will the YTR login capability be implemented into the extraction engine, and what would be the process for logging in once it has been implemented, or is this something that will be done automatically in the background?

I have removed the certificates from Firefox, but at this point it doesn't seem like JMR is actually adding them back in. Going in to view the certificates shows absolutely nothing from JMR, and the issue still persists. The engine update may not have anything to do with the certificates, but it worked just yesterday before the engine was updated and suddenly it no longer works. Firefox hasn't been updated in that time, and the only thing that had changed would be the engine update.

With the DVR application, it doesn't seem to actually remove the toolbar at the top while its recording, which seems to be resulting in a resolution of slightly less than 1080p and slim black bars appearing at the top and bottom due to the DVR toolbar. I'm not sure if this is what's causing the fuzziness within the application or not, but it is a significant and noticeable difference while doing a frame by frame comparison.

In any case, that's less what I'm concerned with; at this point I am really just concerned with YTR functionality and now restoring Firefox capability.


Logs show your missing audio/webm as a content type to download.  

>>> 2017-02-21 20:42:06,213 [5] INFO c4 [(null)] - AsyncProxyManager: 72: HTTP Response doesnt have a content-type (audio/webm) we are interested in

This should be in the defaults. Not having it means no audio stream is being detected and therefore no youtube "stream" (which is made of two separate streams that are muxed together).

Settings > Internet Downloads > Advanced > HTTP and add "audio/webm" as the content type and webm as the file extension.

Please provide your debug logs when clicking on the Reinstall Firefox HTTPS Monitor, so I can see what is happening with your FF.

Login capability for the extraction engine will be in the next release which is actually series 7 of our apps.  In the settings you enter in the url (youtube.com for example) and the username and password to be used. 

Adding audio/webm to download types allows the program to grab the stream now, and with the extraction engine turned off it's actually able to grab YTR streams.

The third debug log I had initially uploaded contains the report from after I clicked reinstall FF HTTPS monitor, but I was able to grab the Jaksta certificate from someone else and import into my Firefox and it is now working again.

Do you have an ETA for when series 7 will be released?

Hopefully next week. :)

Login or Signup to post a comment