Welcome
Login  Sign up

No sound Screen Recorder

Hello what is the proper set up to record video and audio when recording with Screen Recorder on a Mac OS10.12.4

This is my set up.


In preferences I have Sound output set to Internal speakers and input set to Sunflower 2 ch

This set up works most times to capture both video and audio, however sometimes there is no audio. 


If I set Output to Sunflower 2ch (I lose audio while recording) and then under the input tab you can see that the Input Level is recording. On playback I receive both video and audio. I would like to be able to have audio while recording so I can listen and watch. 


How do I set this up to always receive audio while recording and during playback?


Thanks




 


Hi there,


In System Preferences, having output set to Internal Speakers and input set to Soundflower (2ch) is correct - which is the setup that you first mentioned.


In Screen Recorder itself, in Preferences > Advanced you should have it set to Soundflower (2ch) under Audio Options as well. 


This is the correct initial setup, and what you should find is that once you start a recording the Output in System Preferences should change from Internal Speakers to Soundflower (2ch), and then revert back once the recording is stopped. 


Also, make sure that when you go to begin a recording that the Audio in the recording box is set to Soundflower (2ch) and is not set to No Audio or Built in Microphone.

image


Make sure all of this is correct and then let us know if the problem continues. Feel free to send a log file as well as that might help.


Regards

Liam

Jaksta Support


I'm having the same problem described here.  Settings set as you outlined above. As of two weeks ago everything was fine, but now sound records on the captured video but I can't hear sound while recording. Log file attached, I'm on a MacBook running OS 10.12.6 with Jaksta 2.0.0.

Thank you!

log

Hi Penny,


Do you have any speakers or headphones plugged in while you are dong a recording? If you do, try removing them.


It may also help if you set both the Input Volume and Output Volume to the maximum levels when you are doing a recording. This should give you acceptable volume while you are recording and also make sure the recording itself gets good volume.


You can adjust these levels in System Preferences > Sound > Input. The Output Volume is your normal speaker volume, so make sure you turn it down when you are finished recording otherwise it will be super loud.


If nothing else helps I would then suggest doing a hard reinstall - uninstall Screen Recorder, reboot the machine, reinstall the latest update available on the site - https://www.jaksta.com/download/mac/jaksta-screen-recorder


Regards

Liam

Jaksta Support

Hi

I hit the same issue although I took the same actions above.

1. System preference -> Sound -> Input/ouput. Choose Soundflower(2ch) for input and MacBook Speaker for output during screen recoding

2. Make it sure there is no headphone jack plugged in

3. Jakstar preference chooses soundflower(2ch) as default. Also, it's chosen on initial screen recording.


With these steps, I cannot hear the streaming from web and actual recording doesn't have any voice. But if I choose . soundflower(2ch) for input/output, I can hear voice in recording. But this choice cannot allow me to listen voice while I record stream


Let me know how to solve this

Thx


Hi Heeyeol,


Apologies for the delayed response.


Did you try turning the volume right up to maximum while you are doing the recording? Often the sound will drop considerably when the recording starts, and so needs to be turned up a lot to be heard while the recording is taking place and then also in the recording itself.


Make sure to turn the volume back down when you are finished recording otherwise it will be very loud.


Please let me know if this helps or if the problem continues.


Regards

Liam

Jaksta Support

Hi Liam,

On recoding all input/output in MAC set to Soundflower. Increasing volume didn't make voice out for headphone. All sound goes to recoding file. I wonder you understand my issue.

On recording input/output are set to Soundflower(2ch). What I want is to hear the sound together via headphone or MAC sound system while recording it in parallel.

I attach capture on my MAC

Thx

Hi Liam

Do you have update on my issue?

I don't know why response is late.

Thx

Hi Heeyoul,


Sorry again for my late response.


Please try the following and then report back with your results:

  • Perform a basic reinstall of Screen Recorder
    • Uninstall Screen Recorder
    • Reboot the machine
    • Reinstall Screen Recorder
  • Unplug/disconnect all audio devices (wired and bluetooth) such as speakers and headphones
  • Open System Preferences > Sound
    • Go to the Output tab and select Internal Speakers
    • Go to the Input tab and select Soundflower (2ch)
  • Open and start playing a test video with sound
  • Open Screen Recorder and set up a test recording using Region mode
  • Start the recording and turn the volume up to max once it starts
  • Check in System Preferences > Sound > Output that the selected option has changed to Soundflower (2ch)
  • Prepare to stop the recording after about 30 seconds
    • Turn the volume down immediately before the recording is stopped
  • Check in System Preferences > Sound > Output that the selected option has changed back to Internal Speakers
  • Play the test recording and check that it was successful and has audio


If you follow these steps and there is still no audio coming out of the speakers while you are recording then we can investigate further.


Regards

Liam

Jaksta Support

Hi Liam


Still your suggestion didn't work.

I followed all your steps. I clearly confirmed 'this point' below.

But I cannot hear sound while doing screen recording


Open System Preferences > Sound

Go to the Output tab and select Internal Speakers

Go to the Input tab and select Soundflower (2ch)<-------- this point


Open and start playing a test video with sound

Open Screen Recorder and set up a test recording using Region mode

Start the recording and turn the volume up to max once it starts

Check in System Preferences > Sound > Output that the selected option has changed to Soundflower (2ch)<------- this point


Thx

Hi Heeyeol,


At this point it would be good if you could send me a clean log file.


To get a clean log, you will need to do the following:

- Open Jaksta Screen Recorder

- Go to File > Reveal Log File

- Close JSR but keep the Finder window with the log file open

- Delete the log file and still keep the Finder window open

- Reopen JSR (this will generate a new log file)

- Run one test recording for 30-60 secs

- Stop the recording and close JSR

- Go back to the Finder window with the new log file and then attach it here (don't copy and paste the code in it - send the file itself)


Regards

Liam

Jaksta Support

Login or Signup to post a comment