Login  Sign up

BBC iPlayer download error

I keep on getting an error saying that the file cannot be written.

I have attached the log files.

Please help.




Hi Anthony,

I can see from the log file that there is a big error happening in there.

Can you try reinstalling your version of Jaksta Media Recorder and then just try and capture a couple of YouTube videos, then check that they are OK and then try the BBC link again.

Could you please also send through the BBC link so that we can test it here and see if we get the same result.



Jaksta Support


I have tried uninstalling and re-installing and it will capture and convert from the BBC iPlayer website, although not in HD.

Having said that, the file won't open with quicktime even though it is a mov file - but it will play with VLC and can be converted to play with quicktime.

I have tried to capture some videos from youtube and they work fine and are playable with quicktime.

If I then use the URL for the page and the "get" function, it downloads the stream but not properly as once it finishes you cannot open the file.

Here is the link - http://www.bbc.co.uk/iplayer/episode/p04wytcq/peter-kays-car-share-series-2-episode-1

Let me know what you think.



Hi Anthony,

Yes I am encountering the same thing as well, except my file downloaded as an MPEG4 when I did the normal stream capture. Won't play in Quicktime but will play in VLC. Forced conversion after the download works fine for em as well.

The URL bar gave me the same result as you also. 

Unfortunately at this time there are no changes that I can suggest for you to make yourself, as it appears that this is the result of how the stream is delivered, for which we will need to update Jaksta so that it can work around it.

BBC iPlayer has always given us problems and we are always trying to adapt to the changes they keep making to their streaming methods. I will make a note of this so that the dev team can try and cover it in one of the next few updates.



Jaksta Support

Ok, Will keep any eye out for updates. Thanks, Anthony 


Do you have any further news on this, I specifically bought this software to use on I Player  (which it did work on the trial 50% download!) but now all I get is "download error". If there is a light at the end of the tunnel ok otherwise I may cancel as this is the main reason I bought the Media Recorder.  Philip Walker


Here is the log file of the latest problem



Hi Philip,

We will most likely look at implementing some kind of fix for BBC iPlayer into our next update. 

Reports of issues with iPlayer decreased when we release V2 several months ago, but recently they have picked up a bit again so we will look to address them in the near future.

In this specific case though, we will see if there is anything we can do. Can you please provide a link to a specific video that is giving you problems? 

A clean log file would also help.

To get a clean log, you will need to do the following.

- Open JMR

- Go to Preferences > General > Find Log File

- Close JRM but keep the Finder window with the log file open

- Delete the log file and still keep the Finder window open

- Reopen JMR (this will generate a new log file)

- Run one test on a BBC video that you know gives an error/fails

- Close JMR

- Go back to the Finder window with the new log file and grab that file and attach it here (don't copy and paste the code in it - send the file itself)



Jaksta Support

Hi Liam. Thanks for getting back swiftly. Sorry about the large log file - I'm not very up on this sort of thing. Please find attached a single download log which may be of help.

Phil Walker



Deleting and reinstalling the programme using the latest version available has cured the problem for me. Plus also making sure that the conversion is set to default rather than anything else. The only strange thing I find is that when the programme is running and active, my dropbox folder goes offline.

Hi Anthony.

Have tried this but without success. I'm using a Mac so I dont know if there is a setting elsewhere I should check. Thanks for your input.



Hi again Phillip,

So the log shows that something funny going on but it is not very specific about what exactly.

At this point I would suggest doing a full reinstall.

What you will need to do is delete the app (uninstall) from Applications, instead of just reinstalling over it. Then in Finder go to the top menu and then access Go > (holding one of shift/alt/control/command) Library > Application Support > Replay Media Catcher and delete that folder. NOTE: doing this will erase your library file list in Jaksta, but your downloaded/converted files will remain intact. This folder and its files may already be deleted when the app is removed, but it's a good idea to double check and be thorough in case it remains and is reused when the app is reinstalled. Reboot the Mac and then do a reinstall of the latest version (https://www.jaksta.com/download/mac/jaksta-media-recorder) and it will regenerate a new copy of the deleted folder and the application files. 

In the event that their is something broken in your setup of Jaksta, this should fix it.

If the problem persists then let me know and also provide a link to a video that is giving you problems.



Jaksta Support

Login or Signup to post a comment