Login  Sign up

JMR7 is not recording sites JMR6 would

Hulu and Amazon crash on record.  Netflix overscans and records with a browser window box around it.

Vudu, now records, but at extremely low quality.  

Not sure what the issues is but I rolled back to 6 and those issues are gone.


Your OS is Windows 10* 64-bit

* possibly Windows Server 2016


Could you please use this one to get me more debug logs recording from netflix  (it just does some more logging around the silverlight player):



Ok, well this did improve it, it expanded the window to the full size, and before i hit record.  It looked completely normal.  Not like the other with the grey border.  But the recording (attached) still had a small centering issue.  Debug included too.

(3.24 MB)

.9 also fixes my hulu recording issue too (spins infinitely)

Umm. Nothing changed in .9 except for one line of debug that printed out the class name of the window identified as the player to make sure it was indeed the silverlight window, which based on these logs it is.  

Something is interfering with silverlight on your machine and stopping it resizing automatically when the window resizes.

Have you tried, uninstalling JMR and silverlight and rebooting and then installing both again?  Silverlight does have a cache and that might have something strange in it - Im really guessing but its worth a try.

Do you have any IE addins installed?  In IE cog icon > Manage Add Ons.   Take a screenshot and send through and you could try disabling any could possibly be interfering.

no add ins of any kind.  Going to pull it out and reinstall.

Will let you know.  Strange that nothing changed.  Made a big impact lol.  

going to do that (and screen cap) let you know

First sincerely thank you for the time and attention to this. I did find that silverlight was corrupted using M$'s scanner tool, and it uninstalled and re-installed silverlight. This did make a difference but still has a grey bar across the top of the recording.


Next I tried a full uninstall/reinstall of JMR7....9 , clean reboot.  Debug on and now i get 'complete with errors'  it wont record at all.


Last I went back to JMR6 and recorded there, worked fine, no distortions.


The "Digital Video Recorder" driver which is where it gets its sound from is missing according to your log files.

This is installed as part of the installation process and is shared between 6 and 7.  Ie if you uninstall 6 whilst 7 is installed then it will be removed and 7 won't have access to it anymore.

Reinstall 7 and all should be good.

Send me log files once its up and running again as there should be no grey bar at the top.

Login or Signup to post a comment