Login  Sign up

Jaksta fails to record audio

I tested Jaksta in recording mode to capture livestreaming from Amateur.tv. The problem occurs when there is a private, the video continues to run but the sound is muted. Jaksta does not remain silent. This is not the case with other software such as RTMPDump.

Is there any way to correct this?


My testing here is showing this site is streaming using the HLS protocol and not RTMP.  Jaksta detects this and downloads fine using AUTO mode.

Can you please provide further details on how you are recording, your debug logs and rtmpdump command line you're using so I can replicate and see what is going on.

Follow these instructions exactly to collect debug logs: https://support.jaksta.com/discussions/topics/6000009063


Chrome only detects Flash, I do not know how to make it detect HLS.

I use Firefox + RTMPDumpHelper

RTMPDumpHelper automatically detects the stream and it is not necessary to know the command.

I have Win 7 x64

On the other hand , with older versions I could add the date to the file name using


The result was for example video_2017-05-30_12-00.flv

Now it can not be done anymore.

Can you provide the debug logs as requested so I can see what is going on on your machine?

This is my debug logs


Your logs are showing audio data being received, processed and recorded to file.  No errors.  However they are only for a period in the middle of a stream session, you havnt followed the instructions provided and switched on Debug mode before you go to the site and start streaming.  This means all the connection details are not in the log.  You then need to continue in debug mode until the model goes private so that is all logged.  After that you can collect the logs.

Im confused as to how you are getting RTMP though.  Every stream I have tried using firefox (and chrome) is a HLS stream not an RTMP stream.  Are you using an old version of Firefox?  Are you logged into this site?  If you log out do you still get an RTMP stream?


Login or Signup to post a comment