Login  Sign up

Jasmin HTML5

jasmin.com (and her sister sites) have done the inevitable by switching to HTML5, dropping Flash. Streamate did so some time ago but one can force an old version of their site by blocking JavaScript. Sadly there doesn't appear to be a workaround for Jasmin and I don't know how to record their HTML5 streams with Jaksta (if possible). If possible, could you describe the settings I need to change. If not, will Jaksta be able to in the near future?

Even though nothing was captured, I've attached a debug log of entering a 'performers room' (and staying for one minute).

Thank you.


Version, July 1, 2017 :

"New HTTPS WebSocket proxy supports H5 Live protocol (reference implementation Jasmin.com)"

I just want to say THANK YOU.

Jaksta Media Recorder STILL THE BEST !

I still can't download HTML 5 based video from that website or others. I suspect they are still working on HTML 5 capture hence the lack of reply.

Did you try the latest version ?

I tested only the free chat with Mircosoft Edge, Flash is not enabled and It's works for me, the stream is recorded not downloaded and the container is MP4 not FLV.

So it does, in Edge but not without a duration error. Recordings' duration are blank in Jaksta, never 'Complete' and stated as 3 seconds during playback. I usually use Chrome, by the way.

It worked for me for both, Edge and Chrome... until today. It doesn't work anymore with Chrome (tested version and

Still captures fine here.  Chrome Version 60.0.3112.90 (Official Build) (64-bit)

Jasmin is still using the same websocket protocol we implemented support for in Ie nothing has changed from what I can tell.


Please provide debug logs as per https://support.jaksta.com/discussions/topics/6000009063 if you are still having issues.

Using the same version of Chrome but it does not capture.


Your logs are not in debug mode. Please follow the instructions in the link to collect them correctly (especially step 3).

Here it is again: https://support.jaksta.com/discussions/topics/6000009063

Sorry, thought I switched that on.


Cant really tell as you have switched on debug after you started monitoring and there is only 19 seconds of data, but it looks like the websocket was already open when you started AUTO mode as there is no sign of the redirect going via JMR's internal proxy.  

Try this to get us some valid logs:

1.  Close your browser.  If its chrome make sure all chrome processes are shut. Kill them off if you have to.

2.  Open JMR, switch on debug mode and switch on auto

3.  Now start your browsers and go to jasmin and watch a model.

4.  Recording should start afew moments after the cam starts.  If it doesnt, wait a minute and then collect the logs and post them here.

Right, debug mode and auto switched on before opening Chrome. Watched performer for two minutes before collecting logs.


You are still switching on AUTO mode before debug is on so I cant tell what the config is when AUTO starts, but my guess is you have excluded websockets from the proxy cfg.

1. Close all your browsers and JMR

2. Run inetcpl.cpl from "Type here to search"

3. Connections Tab

4. LAN Settings button

5. Check the "use a proxy server .." checkbox to enable the advanced button.

6. Click the Advanced button.

7. Remove any wss:// and ws:// from the "do not use proxy server for addresses beginning with" text area - should look like screenshot below.

8. Click OK

9. Uncheck the "use a proxy server .." checkbox

10. Click OK


If that isnt it then please provide debug logs as per my last post ensuring debug is on before AUTO.

"2.  Open JMR, switch on debug mode and switch on auto"

Anyway, it was the proxy settings so it works now. Thank you.

Login or Signup to post a comment