Login  Sign up

Set default 'quality' for YouTube download

Months ago my posts re downloading YouTube live streams via URL were abandoned but I've revisited the problem and got a live stream going, this one - https://www.youtube.com/watch?v=6a3U8ButYsY

The huge problem is, I cannot have it automatically restart after a drop-out because Jaksta wants me to choose the "quality" to download - and it can sit there waiting while I am oblivious to it because I can't see the popup (even if I were in the room, which I may ot be).  I can't see how to tell Jaksta to select the same quality each time, so that it can look after itself.

(Incidentally, another huge problem that I'd never seen before the past week or two is the Jaksta interface refreshing itself umpteen times per second, truly eye-watering.  Am about to reinstall on top of itself first, if that doesn't fix it I'll have to do an uninstall/reinstall.)


The form that is presented to select a quality/format has two dropdowns on the bottom of it, one or both will be set to prompt.  Change these to the format and quality you want.  Provided a stream with that format is available then it will download automatically at the quality selected.  Otherwise you will be prompted.  They are also available via Settings > Internet Downloads.  


I am not sure what would be causing the refresh you are experiencing.   The list views does not refresh as you describe upteen times per second.  There is probably some conflict with other apps running on your machine.  I know you do screen recording, this can cause flickering on some screens depending on how it is implemented and what is being screen recorded.

Thank you, CRS.  Apologies for late response, this dang flu bug has nearly finished me!

Thank you particularly for bringing on a "duh!" moment re the dropdown boxes, I shall check them out.

I never do screen recording on the same 'machine' as I'm downloading on - and the phenomenon occurs often when there's been no other activity when I wake up and check in it's been doing it a lot.  Never mind, it hasn't done it today so far! :)

Rather then revive the "Muxing ad infinitum" thread, may I ask if it's possible to set auto downloads to use a certain format? 

Today, for the first time, I noticed I had a duplicate coming in and that one version was mp4 rather than the usual flv (from the top 4 streams on starrranch.org/blog)... Well, it's the flv files that are taking forever to mux, so if there was a way of avoiding them I'd be over the moooooooooon !!!

I realise that I often ask you things I should be able to work out for myself, but honestly I have such a heavy and varied workload (self-inflicted, I admit) that I just can't spend enough time troubleshooting.

Thank you again!


Hope you are feeling better.

JMR will pickup what ever protocol/format that sight is streaming and capture that.  There is no way for you to change what the site is streaming unless they give you that option in their video player (or you control the site).  

Some sites do stream different protocols/formats depending upon the browser you use.  For example some sites I have seen stream rtmp/flv when using IE and hls/mp4 when using chrome.

For me, using chrome starrranch.org/blog streams hls/mp4.

Once the stream is captured, you can then convert it to any format/quality using the built in converter.

The muxing of  rtmp/flv streams (which I am assuming is the muxing you are talking about) can be controlled by Settings > Internet Downloads > Advanced > RTMP.  Auto fix and Rebase to 0 are the processes that are happening when Muxing is happening at the completion of an RTMP stream capture.  Bot these settings make it easier to play back flv files in players.  But they can be switched off if you dont want them on.  

Feeling "not as bad", thank you :)

Quote you "For me, using chrome starrranch.org/blog streams hls/mp4"...

On the strength of that I installed Chrome (avoided because it's a RAM-hog, but now I have 32GB RAM so why worry?).

My Chrome now downloads the 4 "main" cams in flv.  The 2 Dropcams at the bottom come from Nest.com and they do download in mp4 in Internet Explorer, and they mux almost instantly.

"Auto fix and Rebase to 0"... I've turned them off but can imagine that I'll regret it, the streams have been easily navigable even when they've been cut off.  I will let you know :)

It's only since JMR version 7-point-something that I've had lengthy muxing of flv files, I'd been using Jaksta for years with very, very fast completion of files, even ones that were many hours long.

Back soon :)


Just to let you know that changing the settings in Internet Downloads > Advanced > RTMP.  Auto fix and Rebase ...

Has FIXED the "Muxing ad infinitum" problem.  No downsides noticed yet.  Thank you!


Login or Signup to post a comment