Login  Sign up

Radio Recorder 7 - Problem with 'Tune' on 'BBC Radio 2' Guide entries

 When I go to the Guide and Search for 'BBC Radio 2' there are two results. On one (URL - http://applian.com/user/rr_record_redirect?id=110) when I press 'Tune'  I get the egg timer for a few seconds then it disappears and nothing further happen. On the second (URL - http://opml.radiotime.com/Tune.ashx?id=s24940&filter=s) nothing happens for a few seconds then I get an error message - "Windows Media Player cannot find the file. If you are trying to play, burn or synchronise an item that is in your library, the item might point to a file that has been moved, renamed or deleted." See attached screen dump. I realise that this is coming from Windows but can you advise please, is there a setting that needs changing possibly.

I am using Windows 10 version 1709 (fully updated) and Intel McAfee LiveSafe antivirus and firewall. I have run SFC /SCANNOW as administrator on the system and found no integrity faults. Interestingly enough, I can schedule a recording from both these guide entries and they record OK. 'Grove' is my default audio player.

If I schedule a recording based on either of these Guide entries, then go to Home>My Subscription and highlight either of these subscriptions and press the 'Tune to station' icon, they behave in the same way as they did when I select 'Tune' against the entry in the Guide.

Unfortunately Windows Media Player does not support the pls format that BBC provides, which is provided by radiotime.   You could change the tuner to use VLC or another player that does support pls.  You would need to change the pls file type association and then the tuner tab to external player.

The applian one redirects to a m3u file which Windows Media can play here.  

So we can find out why it wont play on your machine, please follow these instructions and attach the logs here.


 Hi CRS,

Thanks for that, first problem re pls format is solved having followed your advice, thanks.

The second problem re .m3u files, my default app for this format was set to 'Groove' so I changed it to Windows Media Player and tried again but that did not help, so put into debug mode and tried again. The log zip file is attached.


Can you open http://applian.com/user/rr_record_redirect?id=110 via Windows Media Player directly?

Cltrl-M to display the file menu etc

File -> Open Url

Enter  http://applian.com/user/rr_record_redirect?id=110 and click OK.

Stream should play.  If it doesnt then there is something wrong with WMP on your machine.  Depending on the error message it might give you some idea on how to fix.

If it does play then please do the following

Close JRR

In C:\Program Files (x86)\Jaksta Technologies\Jaksta Radio Recorder 7 there is a file called jwmpp.exe.log4net

Edit that in a text editor

Change the line <level value="ERROR" /> to <level value="DEBUG" />

Close and save.

Start JRR and then perform the the tune action again.

In C:\Users\<user username>\AppData\Local\Temp\Jaksta get and attach the file jwmpp.exe.log  here.

 Hi again,

1) The URL http://applian.com/user/rr_record_redirect?id=110 plays OK when pasted into Windows Media player.

2) I have edited jwmpp.exe.log4net (had to change permissions to do that) to DEBUG Mode saved and rerun the tune function. Output file attached.

(5.35 KB)

 Hi, I don't know if this is significant but I checked another log file in the AppData>Local>Temp>Jaksta folder - 'jradp.exe.log' and there appear to be a lot of errors listed. I notice a new one is created each time I open Radio Recorder, I attach the latest.

(2.77 KB)

Thats just the logging level.  It doesnt actually indicate an error.  The file you attached doesnt have any errors in it.  The info displayed on each line is basic info about your setup.  Logs only make sense to us as developers :)

Ill get to look at the jwmpp.exe.log tomorrow and see what is going on on your machine.

Hi, I was just wondering if you had found anything in the jwmpp.exe.log that I sent you. For your info, I have just upgraded my Radio Recorder to version but the problem with tuning into BBC Radio 2  with   http://applian.com/user/rr_record_redirect?id=110 from within Radio Recorder persists as before and with the same error message (given previously).


Sorry there is nothing in your logs except that WMP cant play the url - it doesn't exist.   

Perhaps the application is blocked by your firewall or other security software on your machine.

Ensure jwmpp.exe which is in the installation folder is allowed through your firewall.

Have checked the firewall and there is already an entry to allow jwmpp.exe through so it is not that. Is there anything else I can check?


Login or Signup to post a comment