Login  Sign up

Livejasmin showing model as offline when Stream Downloader Auto is on and wont record the stream


I’ve been using the “Stream Downloader” with the Auto option on for recording Livejasmin streams and it’s been working fine until a few days ago when some streams would say the model is offline when the Auto option was turned on, now it seems to be happening all the time.


Are Livejasmin now detecting Jaksta and preventing the stream from loading? I tried visiting from a different IP address and from another laptop using the trial version of Jaksta and I get the same issue.


Steps to reproduce the issue:

1: Load Jaksta Media Recorder 7 and visit https://www.livejasmin.com and click one of the models that are online to confirm the stream is working, then hit the back button.

2: Enable the Auto option on the Stream Downloader page and try clicking on the models stream again, this time it will say they are offline.

By the way Chrome gives the following errors when the Auto option is on so resulting in the streams not playing.

vendor.min-a67e2.js:27 WebSocket connection to 'wss://jaws.dditscdn.com/socket.io/?EIO=3&transport=websocket' failed: Error in connection establishment: net::ERR_PROXY_CONNECTION_FAILED

18vendor.min-a67e2.js:27 WebSocket connection to 'wss://jaws.dditscdn.com/socket.io/?EIO=3&transport=websocket' failed: Error in connection establishment: net::ERR_PROXY_CONNECTION_FAILED

Yes working on it.

1 person likes this

Great, thank you for the update, I’m happy to test any beta versions if needed. I look forward to seeing the new version with the issue fixed.

In the mean time, you can open a performer's page with auto off, refresh the page and as it's loading, quickly turn auto on. If you catch it at the right moment, the stream loads and recording begins.

1 person likes this

Thank you for the tip, I’ve just tried with Chrome and Firefox and I’ve not had any success with that method, I tried turning on auto at various stages of the page load but couldn’t get Jaksta to start recording no matter how many times I tried.

I use Chrome as-well. Just turn auto on immediately after hitting the refresh button. If you're alt-tabbing to get to Jaksta, you're taking too long (use Jaksta's small interface if it's otherwise hidden behind your browser).

No it doesn’t work for me unfortunately. I tried the small interface version and I had it placed above the refresh button for quick access.

If I hit the refresh button and then enable auto strait away, when the page finishes reloading it just says the model is offline. If I delay a little bit before hitting auto the stream loads but in both cases no stream is recorded by Jaksta.

OK, you're turning auto on too quickly then. I have Jaksta with the small interface in the bottom right of my screen.

No unfortunately still no luck with this, I’ve tried doing it straight away and with varying delays and it doesn’t work for me.

Hopefully CRS will have a solution and new version of Jaksta out soon? any updates CRS?

I have had to redevelop the internal proxy used by JMR as the old one just could not support the new websockets features that livejasmin and a couple of other sites have just started to use.  As part of this we have moved from targeting .net 4.0 to .net 4,5. 

Testing so far shows much quicker page load times when AUTO is on.  And more importantly for you guys livejasmin is capturing correctly. 

Lots of regression testing happening at the moment.  I hope to have a beta out by Monday.

Great, thank you for the hard work.


I look forward to testing out the beta version when you make it available, I’ll keep checking this thread for the link .

Here is a beta which should capture from livejasmin again.  http://downloads.jaksta.com/release/jak7/JMR7/

There has been a significant redev of some of the internals and a migration to use .net 4.5 (dropping XP support), plus a bunch of other internal upgrades.   If you have the time test it out on some other sites as well.  

Any issues please respond with debug logs.


I’ve just tried the beta version, and unfortunately I’m still having the same issue.

I tried using both the Winpcap and Network Monitor options in the Settings->Internet Downloads page .


I’ve attached the debug logs for you to look at. In the meantime I’ll go ahead and try some other sites.

If there are any settings I can change let me know.


Actually I’ve just tried it on another laptop and it is working on that one, so I’ll try comparing the setting and perhaps do a fresh install instead of the upgrade and see if that solves the issue.

And if you see anything from the logs files that would explain why it’s not working on the laptop I normally use let me know.

Login or Signup to post a comment