Login  Sign up

Livejasmin showing model as offline when Stream Downloader Auto is on and wont record the stream


I’ve been using the “Stream Downloader” with the Auto option on for recording Livejasmin streams and it’s been working fine until a few days ago when some streams would say the model is offline when the Auto option was turned on, now it seems to be happening all the time.


Are Livejasmin now detecting Jaksta and preventing the stream from loading? I tried visiting from a different IP address and from another laptop using the trial version of Jaksta and I get the same issue.


Steps to reproduce the issue:

1: Load Jaksta Media Recorder 7 and visit https://www.livejasmin.com and click one of the models that are online to confirm the stream is working, then hit the back button.

2: Enable the Auto option on the Stream Downloader page and try clicking on the models stream again, this time it will say they are offline.

It works for me, plus Jaksta using .NET 4.5 no longer crashes when I'm using iTunes. It does however, crash occasionally when on Jasmin's website; first time was when a performer left the room, so to speak. I'll try to remember to create logs next time.

On the laptop that I can get Jaksta running on, it crashed 4 times in the last hour when recording livejasmin streams.


I’ve attached the logs from Windows 7 ( Control Panel\All Control Panel Items\Administrative Tools -> Event Viewer) for you to look at for one of the crashes (each crash event looked the same). Each time it crashed it created an “Application Error” and a “.NET Runtime” error event.


In my case I was recording 3 or 4 livejasmin streams and I think the crash happed just after one of the streams finished but not 100% sure.


Thanks for the testing.  That crash when a model goes of line is an interesting one.  I think this version will stop it,  but there is a lot of talk on google about it being an issue with .NET 4.5 and it being fixed in a windows update.  Could you please ensure you have definitely applied all windows updates to do with .NET.


Also when submitting logs please do not turn on "include network trace in log files".   Please resubmit debug logs for the computer capturing is not working on so I can have a look.

Ok, I’ve attached the new logs as requested without “include network trace in log files” enabled.

I tried two models with auto turned on to show the issue and then at the end I tried one model with Auto off, hopefully, the logs will show the difference so you can track down the problem.

I tried installing the last beta as a fresh install the other day, but it didn’t make any difference, when installing JMR7- I used the update option.


On the other laptop JMR7- seems to be ok so far and hasn’t crashed, I do however have a few .NET updates that have not been installed yet, I’ll continue testing and if there are any more crashes I’ll install the .NET updates and test again.


======== UPDATE =======

Just before posting the above message I decided to compare the Internet Explorer Proxy settings as they are global and used by chrome and the laptop that was working was using port 51919 while the laptop that wasn’t working was using port 3129 which I had manually set a while ago when I had an issue were JMR was not working on any site.

Since removing port: 3129 JMR is now working with Livejasmin and seems to be using random ports for the proxy now, such as 51919, 4002 etc


As you have mentioned, your logs show you had a http and socks proxy configured on localhost:3129.  

This was not our software that set that.  We only set the https proxy when AUTO is on and it is unset when switched off.  All https traffic can then be monitored for media streams.  Yes the port changes as using a constant port could conflict with other software running on your machine - this is not an issue.   We do not set the http proxy at all.   HTTP traffic is monitored as part of the network monitor (Winpcap).

Anyway Im glad it is now working for you on both computers.  Let me know if you have any further crashes or issues.

Login or Signup to post a comment