Login  Sign up

Lost connection

I have been downloading from this site a long time without too much problems. Now, suddenly since, I guess Thursday,  I can still watch the program on line but can't download it anymore. Before some programs were approachable in a regular way from the US, and some shows I needed to use VPN with Dutch connection. Now nothing works anymore. As VPN-provider I use ExpressVPN nowadays to connect to Dutch sites.

It's about the site: https://www.npo.nl

Example of a link of a program that I wanted to download is:


The site had created limitations before but together with you we always succeeded to bypass the wall, so I hope you can find out what is going on.
Gert Schreuder

By the way, downloading from YouTube is no problem.
Based on what I read in the forums I zapped the latest version of Media Recorder and all its connected preferences etc. and reinstalled it with an older version (2.0.0 (219)). This did not work.

One more thing. Since previous problems and a lot of downloads of video clips that I was not interested in I started to switch off the automatic downloads and copied the url's of the programs I wanted into the Media Recorder. That worked perfectly for me.

Switching on the automatic download did not resolve this problem.


Hi Gert,

I was able to successfully download and play this video using the URL Download bar. I did this without having to use a VPN or any other program to access the content. 

This suggests that Jaksta is working properly and that the issue may stem from the use of the VPN service, as it is the only other major difference between your scenario and mine. 

The next best thing to would be for you to send in a clean log file. Make sure you are running the latest version of Jaksta available.

To get a clean log, you will need to do the following:

- Open Jaksta Media Recorder

- Go to Preferences > General > Find Log File

- Close JMR but keep the Finder window with the log file open

- Delete the log file and still keep the Finder window open

- Reopen JMR (this will generate a new log file)

- Run one test on a standard video stream that you know gives an error/fails 

- Close JMR once it fails or wait until it crashes

- Go back to the Finder window with the new log file and attach it here (don't copy and paste the code in it - send the file itself)



Jaksta Support

Hi Liam, thanks for checking, it limits the options and is a good and important step for the deduction to find the problem. Still this blockage appeared overnight and nothing remarkable was done in between (as far as I know).
I will follow your steps later today. I already re-downloaded and installed the latest version as the older version did not solve the problem.
I will come back to you later today.
Thanks for now.
This is the same program as I sent before.


This is the text it gives with the failure:


Hi Gert,

From looking at the log file there are two things I can suggest. 

Under Preferences > Streaming there is a setting called Always Record HTTP. It looks be on, so try turning it off and then test again.

I would also recommend updating your Mac OS. Whilst Jaksta can and should run on 10.11.6, it is somewhat outdated at this point and for this particular site it may be the difference between it working and not working. This is also the only other major difference between your system and my own, and we know that it works for me.

Try making these changes and let me know how you go.



Jaksta Support

Thanks for your reply Liam, I will try your suggestions this afternoon.
And about the MacOS, the thing is that Apple updates its system software time after time, with the result that the computer slows down, and I am forced to buy a new laptop again (this one is already the third one in 8 years). Above that, several programs/applications do not work anymore on the new OS and have to be purchased again (sometimes) because several software developers use it as an extra moment to sell me new facilities that, though beautiful and nice, I don't need. But, I realize that at a certain moment I can't delay it anymore. So I will seriously look into the need of that. Thanks anyway. I will try the HTTP first.


Well Liam, the HTTP thing did not work and I want to solve the issue before I consider upgrading my operating system, unless someone can explain me why I should and what it would change. I wonder what change has been made and by whom, that caused my problems. Something happened over night and I can hardly believe that someone has deliberately made a change so that I could not download anymore.

The error message states:
Jaksta Media Recorder[40559]: Download Failed msg:Unable to download webpage: HTTP Error 410: Gone (caused by HTTPError()); please report this issue on https://yt-dl.org/bug . Make sure you are using the latest version; type  youtube-dl -U  to update. Be sure to call youtube-dl with the --verbose flag and include its complete output.
So there is reason to suppose that my problem has to do with a HTTP Error.
The other thing is that the error message that pops up tells me that it has to do with "youtube-dl". I have no idea what that is about, but the only thing that I seem to understand that that is something that has to do with "Windows", so with the Microsoft environment.
So, this looks like there is not an easy solution as you assumed. I wonder what HTTP is there more to check which could cause problems?


Hi Gert,

The error looks to be coming from the server, so it might be detecting the VPN and then closing the connection. We will see what we can do to replicate that here.

In the meantime can you please do another test, except this time do not use the URL bar and only attempt to download via the default auto-capture method. 

Get a new clean log file from this test and send it through.



Jaksta Support

Okay, I tried that with two programs (without VPN), but it didn't pick up anything automaticly, not even youtube clips. Youtube still downloads though, when I COPY/past the url. The strange thing is that in the last second of downloading downloading starts again in some way adding minutes to the download time until it stops downloading and than after some time restarts again and completes the download. That doesn't disturbs me, but I want to tell you everything that I see.
By the way, I did not use VPN last week, as I knew the programs I tried are normally not limited to the Dutch area.


I downloaded a more recent version of "youtube-dl" from their site, and replaced it with the one that is located in the Library/Application Support folder. But although the error message changed in the one I enclosed here in the attached file, it did not result in a well working download. Probably while the file is not integrated int the application as it should. So, still not found a solution myself.


Hi Gert,

Something else that you could check is your proxy settings.

Open: System Preferences > Network > Advanced > Proxies

There are two options that you need to look at: Web Proxy (HTTP) and Secure Web Proxy (HTTPS). These are the proxy settings that Jaksta turns ON and uses when monitoring is active.

They should both have identical settings, which can be seen below. If they do not then you can edit them manually. 

Have a look at it and let me know if they are already correct or if fixing them helps with your auto-capture downloads.



Jaksta Support

Login or Signup to post a comment