Welcome
Login  Sign up

JMR won't schedule a download from this livestream

Hello Jaksta Support,

I started JMR, set Auto on, then played the TV Livestream from this webpage.


https://www.mdr.de/mediathek/livestreams/fernsehen/index.htm.

The window shown in attached JPG came up and invited me to choose a stream quality. So I chose 1960 Kbs and got a file 960x540. So far so good.

On the Jaksta home screen I looked at properties for the file, and it showed me this stream address -


http://mdrsnhls-lh.akamaihd.net/z/livetvmdrsachsen_de@513998/manifest.f4m?g=CJCIJDTXNIZE&hdcore=3.11.0&plugin=aasp-3.11.0.23.3


I assumed that this might be the direct stream address for this specific 1960Kbs stream, but it isn't. I set Auto OFF and pasted it into the URL field - the same "please-choose-a-stream-quality" window appears and I have to choose a stream before we go any further. So then  I set up a test schedule with that stream address, and it didn't work, JMR dowmloaded only an .f4m file (attached)


So it looks like I can't schedule a recording from this stream in advance, I actually have to be there at start of the download, to choose a video quality. That's not much use to me, I don't feel like getting up at 3am to start a download. Is there any way around the problem? My other German TV livestreams give me a specific address for a specific stream quality, so scheduling works fine. This stream is different.  Is there any way round the problem?


Thanks,

Clinton Solon


f4m

The media stream urls for that provider change - they use expiring urls.


You can use "Auto Detect Download" capture method and select the prefered quality and prefered format from the multiple streams prompt or Settings > Internet Downloads so you no longer get the multiple streams detected prompt.  At the scheduled time AUTO is switched on and the url will be launched in the browser and if the stream starts playing then it will be picked up and downloaded based on the settings you selected.


However this site is click to play so unless there is a setting somewhere on the site to make it auto play then you may still be out of luck trying to schedule something from it.


Thanks for your reply, although I'm having trouble understanding it. What is the relevance of the "expiring URLs" that you say this site uses?

The URL that I used, ie.

http://mdrsnhls-lh.akamaihd.net/z/livetvmdrsachsen_de@513998/manifest.f4m?g=CJCIJDTXNIZE&hdcore=3.11.0&plugin=aasp-3.11.0.23.3

is not "expired", in the sense that if I first set preferred download quality to HIGH, set AUTO OFF, no browser running, and then  enter this URL in the homescreen, then away it goes, the download runs and I get a playable file.

So what's with the "expired " URL?

Now that URL is already in the scheduler, so when Jaksta starts from the scheduler, why does it behave differently from when I start it manually with the same URL?

Presumably the first thing Jaksta does when I do the download manually, is to download that .f4m file, then it uses this file to get the necessary info to access the required stream. But when the Scheduler does the download, it downloads the .f4m file then stops, doesn't know what to do with it. That's very strange.

What it amounts to is that I can do the download manually with a single paste-and-click, but the scheduler can't do that paste-and-click for me.

Could you please have another think about this? Would it help if I set de-bug mode on and send you the logs?

Thanks,
Clinton Solon


That url gets an access denied when trying to access it from here.


When I AUTO that site I actually get a HLS stream detected, not a HDS stream, which is the url you have.  The HLS stream urls do expire and are therefore not suitable for a scheduled recording.  As the url you have provided gets access denied from here then it was assumed that it is also an expiring url.


If you say the same url is accessible over a long period then I guess it is not expiring and therefore could be suitable for a scheduled capture.


If that is the case and the URL downloads via the extraction engine (Entering the url in the Enter (or Drag and Drop) the url of a video page to download) as you state it does,  then simply set your scheduled capture method to Direct Download By URL and the Download Method to Extraction Engine URL as per the image below.  You will need to select the prefered download quality etc so you don't get a multiple streams prompt (as you have done).


image


If you are still having issues then please provide debug logs.


 

Problem solved! (Well almost, and the bit that isn't, I can live with)

I was using Normal URL instead of Extraction Engine URL in the scheduler. Using Extraction Engine URL, with preferred quality HIGH,  the scheduler works fine.

I never thought to try EE URL, because the streams from my two other TV channels, eg this one -

https://zdf1314-lh.akamaihd.net/i/de14_v1@392878/index_2296_av-p.m3u8?sd=10&dw=0&rebase=on

work fine using normal URL. (I just tried them and they also work with EE URL.)

Re your comments - "That url gets an access denied when trying to access it from here".

and

"When I AUTO that site I actually get a HLS stream detected, not a HDS stream, which is the url you have"

It's geoblocked for me. If I turn off my DNS proxy I can't get the stream from the webpage, or do a direct download with Jaksta.


And when you AUTO the webpage (https://www.mdr.de/mediathek/livestreams/fernsehen/index.html)  you get an HLS stream detected?
Now I'm really puzzled. Can I see what you got please?

As for the tiny bit of the problem that isn't solved - I have to set preferred quality to high/medium/low otherwise I get prompted.
HIGH gives me 1280x720  3744Kbs which is more than I need, MEDIUM gives me 640x360  1184Kbs which looks a bit awful. What I want is the stream in between, ie. the 1960 Kbs which looks pretty much the same as HIGH on my fairly small TV. It would be nice if I could schedule that somehow, but I suppose I'll just have to stick with HIGH. I can live with that.

So - problem seems to be solved and thanks very much for your help.

Clinton Solon





Login or Signup to post a comment