Login  Sign up

HD youtube video downloading as 640 x 360

This video says it's 1080p HD on youtube, but the file Jaksta downloads is just 640 x 360. Possibly related, it also only gives the download the title "unknown.mp4" instead of the video's actual name. Is there any way to get the full HD download?


Hi Luke,

When I tested an auto-capture of that video I ended up with a playable 1920 x 1080 .mp4 file. So I cannot replicate your issue.

Sometimes it can come down to the browser, so if you haven't already then I would suggest trying a different one. Try Chrome if you haven't already as that usually gives the best results.

If you continue to experience this same problem, then it would be best to send through a clean log file.

To get a clean log, you will need to do the following:

- Open Jaksta Media Recorder

- Go to Preferences > General > Find Log File

- Close JMR but keep the Finder window with the log file open

- Delete the log file and still keep the Finder window open

- Reopen JMR (this will generate a new log file)

- Run one test on a standard video stream that you know has a problem

- Close JMR once the download and conversion is complete

- Go back to the Finder window with the new log file and attach it here (don't copy and paste the code in it - send the file itself)



Jaksta Support

Liam, I had been using Safari before, so this time I tried Chrome. It does name the file correctly now, but still just getting 640 x 360. Also getting two copies downloading simultaneously, strangely.

I even tried switching to another user account on my Mac, and got the same result.

I think I followed the instructions correctly to attach my clean log file, if you could take a look.


Hi Luke,

Looking at the log file it definitely says that it is getting the video at that resolution, and there is no conversion set.

That suggests that is how it is getting ti straight from the stream without any alterations. 

This might sound obvious, but are you setting the quality to 1080p in the YouTube player settings?

Something else that I noticed is that your Mac OS is outdated. I would suggest updating it as sometimes it can have an effect on the programs ability to operate, as well as it's a good idea for the standard reasons - security, general functionality. It's not always the case, but sometimes updating the OS can resolve issues such as these.



Jaksta Support

I just tried booting from a mostly fresh High Sierra  volume and still got the 640 x 360 file. And yeah, I have double checked the quality setting in the YouTube player. The fact that YouTube says it's in HD is the only reason I am even looking into it, because the original is from a 1968 TV broadcast and doesn't look so great to begin with. I'm just trying to ensure I get all the detail available.

Maybe it's possible for YouTube's player to misleadingly offer HD settings on a video that is only 640 x 360 to begin with? Curious to know if you have any insight into that. But beyond that, if you don't know what else to try, I'm willing to settle for what I got, as I'm not sure I can see any loss in visual quality.

Hi Luke,

Apologies for the delayed response.

I asked development about this and they said essentially that because of the streaming protocol used by the video/site, Jaksta has to guess the video quality to download because it cannot tell from the URL.

It picks the best video quality available based on a maximum bandwidth value, which is to prevent it from just going straight for the highest quality stream available and then throttling the internet to download a massive file.

Depending on what the quality of your internet is like and if it is not as good as ours, then that may explain why I could get the highest quality video and you could not.

If you haven't already tried it, you could give the URL downloader bar a go as it does operate a bit differently and can get different results. However, it will likely take quite a bit longer than the standard stream download.

Hope there is something here that helps.



Jaksta Support

Login or Signup to post a comment