Welcome
Login  Sign up

JMR 7.0.2.9 => DVR still not working for Windows 10 1903 Pro

When recording sound is OK but video is black :(

Will not provide more details as problem has been reported many many times?


I have seen that JMR 7.0.2.1 was suppose to fix problem but does not work on my system.

What is status


FYI tested on Win 8.1 VM and works fine :)


7.0.2.1 did implement support for 1903, but then ... The DVR feature has been busted again by Chrome 76 and some windows updates.  Working on a solution ... again ...

Thank you for the information.


May be this also explains that about 10 days ago it worked on my Windows 10?

Here is a description of how it worked:

I was trying to record TV from my ISP @ https://chaines-tv.orange.fr on my Win 10 system. Therefore, after clicking on the DVR button of JMR, a browser window opened and I could select the channel to record then I clicked on record button. To my surprise the browser window closed (normal) but a new large independent window opened (?) displaying the recorded channel. After stopping the recording, this window was closed and the image / sound where recorded correctly. As I said this behavior is now broken and DVR only record sound but with a black image.


Meanwhile to work around this problem I run JMR on a Windows 8.1 system under VMWare. It works but the behavior is different: after clicking on the record button, the browser window close and a small window inside the left panel of JMR open at the bottom and display the recorded channel (this is the behavior I am used to).


I really like the behavior with the large windows as it is much more easy to follow the progress of the recorded windows.


Questions:

  • Was this large windows opened by JMR?
  • Was this new behavior of the “recording windows” introduced in 7.0.2.1?
  • Was this behavior removed in 7.0.2.9?
  • Will this be the behavior (having a large independent window) when JMR is finally fixed?
  • Any plan to be able to hear sound when recording (important improvement)?


IMPORTANT INFORMATION

Guess what: after writing the above description I have decided to test several previously released versions of JMR and here is what I found:

 

  • JMR 7.0.2.1 has broken recording
  • JMR 7.0.2.4 Recording is working fine with separate windows displayed
  • JMR 7.0.2.9 has broken recording

 

Here is a more detailed description of the behavior in 7.0.2.4

As mentioned in previous post, a “large window” opens during recording. This window is stuck in the upper left corner of the desktop and cannot be moved. A “player window” is located inside the large window, and it is possible to move this player window inside. In that case the “player window” is clipped inside the “large window” and the background is black. The recorded video is simultaneously displayed inside the left JMR panel.


I have attached a picture of my desktop during recording (red arrow points to “large window”, blue arrow to “player window”, and green arrow to JMR player window) 


It often happens that the large windows disappear after sometimes, however the recording continue correctly and the recorded video is still displayed in JMR left pane.

 

This may be interesting to developers. They almost fixed the problem with 7.0.2.4 even though behavior is still unstable. Unfortunately 7.0.2.9 breaks recording again


record.png
(960 KB)

Thanks for your investigation/feedback.  Very helpful.


So two things have hit at the same time.


Chrome 76 doesnt allow the UI to be controlled in the same manner as we currently do, and a windows update has changed some of the undocumented API calls we use.


You can fix the window opening on screen by doing a full reinstall (deleting your library and settings) OR by deleting the file C:\Users\<your username>\AppData\Local\Jaksta Media Recorder 7\JakstaDVRvd.18362.generated.dll.


This auto generated file will be regenerated with the new undocumented api calls we use when the DVR starts recording.


Ive changed the installer to remove the autogenerated file on and upgrade install, but the Chrome changes Im still working on.  DVR will then work but you will see the title bar in the DRV recording.


Ive updated the KB to reflect the current state of play:   https://www.jaksta.com/support/windows/kb/windows-10-1809-dvr-recordings-are-blankblack-videos-6000221913 

More tests


Windows 10 Pro 1903 (build 18362.295) on HW – Chrome 76.0.3809.132 – JMR 7.0.2.9

  • - Removed JakstaDVRvd.18362.generated.dll file. Reinstalled JMR 7.0.2.9. When recording with DVR the JakstaDVRvd.18362.generated.dll file is recreated
  • - The DVR browser windows open and after hitting record button a new large windows open. This windows contains a title bar and often disappear after sometimes. The small recording window in JMR left pane is also displayed without the title bar.
  • - Recording of video/sound seems ok but resulting video contains title bar.

 

Windows 8.1 V6.3 (9600) on VMWARE - Chrome 76.0.3809.132 – JMR 7.0.2.9

  • - No JakstaDVRvd.18362.generated.dll file created
  • - The DVR browser windows open and after hitting record button no other window is opened. The small recording window in JMR left pane is also displayed without the title bar.
  • - Recording of video/sound is ok and resulting video contains no title bar.

 

Windows 10 Pro 1809 (build 17763.437) on VMWARE – Chrome 76.0.3809.132 – JMR 7.0.2.9

  • - When recording with DVR a JakstaDVRvd.17763.generated.dll file is created
  • - The DVR browser windows open and after hitting record button a new large windows open. This windows contains a title bar and often disappear after sometimes. The small recording window in JMR left pane is also displayed without the title bar.
  • - Recording of video/sound seems ok but resulting video contains title bar.

 

Problem with DVR browser

I did the above tests by recording Netflix video. The reason is that the DVR browser seems to always work correctly with Netflix.

But when I test the DVR Browser on TV from my ISP, in most cases the Web page is not displayed correctly. For example I specify the https://chaines-tv.orange.fr address and click the DV record button, the DVR browser window open at https://chaines-tv.orange.fr/#live/home which is a normal redirection. For a very short time the web page is displayed correctly but rapidly the content of the windows turns black and after 30 seconds the window is closed and the recording (of a black video) is completed.

 

As already mentioned it would be nice to the sound of the recorded video, because it is sometimes difficult to know the status of the recording on a very small window.


Login or Signup to post a comment