Login  Sign up

Some Myfreecams Streams Not Downloading

Having trouble with some, not all, streams from Myfreecams. It appears to happen only on HD streams (1280x720 and above). The DASH protocol appears to be recognized, but the stream isn't downloaded. Attached is the debug log of one example. Hope this helps!


Here's another example.


One more for good measure.


This may be a better example. The quality is displayed as MP4 (DASH), but nothing is downloaded.


Thanks will look into it.

Any luck so far?

More models seem to switching to this format of streaming too.  I have monitors that worked before that are now trying to download a generic DASH stream and failing.

Any word on if this can be fixed?  Two of my favorite models are now broken.

The logs are showing connection closed from the server end and in some cases connection refused.  

Perhaps they are limiting the number of connections that can be made to their servers from the one machine and throttling?  

Try configure your monitors so there is more time between checks and see if you have more luck.

@Ovw9 - They havnt changed streaming protocol.  Which models are you having troubles with?  Please provide debug logs.

Here is a log.  Clean boot only one monitored model online.  Operation time out.


Turned monitoring on for another random online model and it worked.  This only happens to models that are streaming in widescreen.  When the model that is timing out was streaming in 800x600 I had no problems.  She switched to 1280x720 and now it rarely works. Not sure if that is related.

(26.8 KB)

It doesn't seem to be a problem with widescreen per se, because I've had no trouble at 960x540, one of their widescreen formats. It's something about the 1280x720 format on MFC that causes hiccups.

Login or Signup to post a comment