Login  Sign up

Moving files to different volume causes Finder to hang

For a couple of weeks now I have had a problem that repeatedly made me have to force shutdown my Mac Pro desktop. Today, as I was attempting to move a newly created file to a different volume, the Finder AGAIN hung. On one of the restarts I again tried to move the file and got an error message that the file could not be "opened" because it was still in use

That instantly led me to realize that all of the other time-consuming hangs had occurred with files I had created with Version 2.2.5.

There was another hang, several days ago, that, when I got the machine back up, I noticed another but familiar problem (all of a sudden browser couldn't find any address). I checked via System Preferences and, sure enough, even after a re-start, the proxies that Jaksta sets up were still active. I turned them off and the browser could find the URLs.

I do not recall how long ago this upgrade got installed. It seems that this problem of clotting up the Finder is more recent, but I may not have paid specific attention to a notice.

1 Comment

Hi William,

I don't quite fully understand the circumstances of the hang issue. Are you saying that Finder hangs when you try to move a file (from one volume to another) that has been newly created by Jaksta after it has finished downloading and converting? 

If that is the case then I'd like to clarify a few points:

  • Are you confident that you only tried to move the file once Jaksta had marked it as 'Completed' in the library list?
  • Do you only get this problem when you try to move the file from one volume to another? What happens if you move it within the same volume?
  • Is there any chance that the file was playing in a media player when you received the notice saying that the file was 'still in use'?

In any case my first suggestion would be to do a basic reinstall - uninstall, reboot, reinstall. We have a new beta available that you can update to and which may also help. 

If you opt to go for the beta then you can get the installer here - https://download.shedworx.com/jaksta/beta/2.2.6_291/JakstaMediaRecorder.pkg

When you first attempt to run the beta installer you will receive a Mac OS notification saying that it can't be opened because it cannot be checked for malicious software. Click 'OK' and then go to System Preferences > Security & Privacy > General and click on 'Open Anyway' down the bottom. It will either run the installer or another similar notification as the first will appear and you just need to click 'Open' and then the installer will run.

As for the issue of the proxy settings staying on and breaking the connection, that is not unusual and is a common side effect of doing an reboot or anything abrupt to the machine whilst Jaksta is still running. Not much t be done there apart from find the setting sand turning them off manually, which you did.



Jaksta Support 

Login or Signup to post a comment