Login  Sign up

Unexpected error configuring the HTTPS/SSL monitor for Default LAN

I am getting the "Unexpected error configuring the HTTPS/SSL monitor for Default LAN" message.

I have done what you suggested in the couple of support posts about being sure to set it as 'DefaultLAN' but it does not work for me.



(217 KB)
(101 KB)


Thanks for the account activation.

I have attached the logs below.



The error (0x2F92) is because you can't change the proxy settings on your computer.  A google search indicates that this maybe because:

1.  WinHTTP Web Proxy Auto-Discovery Service is not running or enabled.

2.  A windows update has "broken" the proxy cfg in windows.

Can you change your proxy settings in Internet Explorer?  IE -> Tools (the cog icon) > Internet Options > Connections tab > LAN settings > Advanced?

JMR uses an internal proxy to detected media streamed over HTTPS.  This proxy is switched on when you click AUTO and off when you turn it off.


I have looked at this and the WinHTTP Web Proxy Auto-Discovery Service was disabled. So I enabled that via the registry as in image '3' below to 'automatic'. I cant seem to force it to start from boot, just the 'automatic' option. Should I try the 'manual' setting from boot?

The other two images show what I am getting for the IE route you mentioned.

I still cannot change the LAN settings to automatically select the proxy.

When I try to manually start the WinHTTP Web Proxy Auto-Discovery Service via the 'Component Service' I get image 3 below.

If it down to 'associated devices', does anyone know what they are and how to enable them?

Any ideas are greatly received.

(353 KB)
(95.1 KB)
(159 KB)

Min is set to manual.


Perhaps see if there is more info about what is wrong in your windows event log.


I have got JMR to run without the error by totally uninstalling it and reinstalling it and the NCAP, and setting WinHTTP to manual.

However, it does not now find any HTTPS feeds.

Could you also give a hint as to where I can find the specific event log.


Please provide debug logs again if the HTTPS monitor is now running without error.


I have attached the log. Was trying to record this video off the BBC:




Your logs dont show you going to that page.  Make sure AUTO is on before you open your browser and go to the page you want to capture from.


1. Started Jaksta.

2. Started Firefox.

3. Ran video link.

Nothing shows up in the recording box, no multiple streams box opens as per your image.


 I tried again with a different page, same site and I think that should be visible in the logs attached.



I tried again today with the same result.

I did notice when I then tried to download it by the "download from the URL" it said that there was a problem with SSL if that explains anything.

At the moment the software is useless to me. I can use OBS studio, but I want to be able to do other stuff in the foreground with sound.

Thanks for any help.




Your logs show the stream being detected and a capture starting (which would is appearing in the JMR UI) but show some issue with your settings for preferred download quality and preferred download format.  No stream is selected and the capture stops.

What do you have these set to?

Settings > Internet Downloads

I had it set at 1080p quality. Changed it and it does now offer me a choice - but crucially not on Firefox!?

Why is the "Preferred Download Quality" not an advisory as it implies? I only set it as I thought, if there were a 1080p download on offer, it would choose that one, but if not, it would go for what was on offer?

In the past it just downloaded the stream and didn't give a selection of streams? Did you change that in the later software versions?

Login or Signup to post a comment