Welcome
Login  Sign up

Unexpected error configuring the HTTPS/SSL monitor for Default LAN

I am getting the "Unexpected error configuring the HTTPS/SSL monitor for Default LAN" message.


I have done what you suggested in the couple of support posts about being sure to set it as 'DefaultLAN' but it does not work for me.


Thanks

GC

jaksta2.jpg
(217 KB)
jaksta1.jpg
(101 KB)

Let me have a look as it should be working as you described (it is advisory).  


There are new max resolution settings in that list, from version 7.0.12, intended to give greater control, than just the   Lowest, Median, Highest that were the only options previously.


Please provide debug logs from Firefox if you arnt getting a prompt at all from that browser, or a download that is in error with "No stream selected to download"

https://www.jaksta.com/support/windows/technical/jaksta-media-recorder/how-to-generate-debug-logs-6000009063

 Attached the latest log.


Here was the order of actions:


1. start Jaksta with 'Auto' running.

2. start Firefox to blank page.

3. select bookmark page 'https://www.bbc.co.uk/news/video_and_audio/headlines/53631866/first-spacex-crewed-mission-lands-safely'

4. click 'Play' button.


As you can see from the logs, nothing from Firefox is picked up by Jaksta.

zip

This beta should correct the issue where an available stream was dont being detected when you had a preferred quality set

 

http://downloads.jaksta.com/release/jak7/JMR7/7.0.20.0/JMR7-7.0.20.0.exe

 

Your logs from trying to use Firefox show that no data was requested for that page https://www.bbc.co.uk/news/video_and_audio/headlines/53631866/first-spacex-crewed-mission-lands-safely'  through the internal proxy.


This could indicate a couple of things:


1.  The page and video data is cached in your browser and not being requested again.  Hold the shift key down and click the firefox refresh button to do a hard load of the page, with AUTO on.

2.  The Firefox profile you are using is not configured to use the system proxy settings.  See  https://www.jaksta.com/support/windows/kb/firefox-not-detecting-https-streams-in-auto-mode-like-youtube-6000074222


Thanks.


I set the Firefox proxy to "system proxy" and it now picks up the stream.


I have installed the v20 Beta and tried to record the same BBC link as above. It works!


I also set the preferred stream to 1080p and it ignored that to download the next highest at 720p.


So, success there too.


Thanks again.


The one thing that is disappointing, is that when downloading the BBC stream it comes up titled "Nothing to see here" and does not change once the recording has ended. I would assume it is not looking for a title in the places it should.

AUTO mode naming is an "art form" not science as the stream protocol detected sometimes has no title in it and it is difficult to try and trace back to see what title is from - the fall back is the active window title at the time the stream is detected.


You have full control over the checks I try and do to detect a title


Settings > Internet Downloads > Advanced > Naming Rules.


image


The Properties > Progress log tab shows which naming rule was applied in there.


Thanks.


I have all those set to on here. Maybe it is just the BBC who don't name their pages.

Oooops!


Jaksta v21 has just reverted to the original "Unexpected error configuring the HTTPS/SSL monitor for Default LAN" message.


Does this mean I have to uninstall and reinstall again?


I have not been installing anything other than an Adobe Lightbox update.

 logs attached

zip

Same issue as you originally had where a proxy cant be set on your machine.  


1.  WinHTTP Web Proxy Auto-Discovery Service is not running or enabled.

2.  A windows update has "broken" the proxy cfg in windows.

Thanks.


It looks like I will have to edit the registry every time Windows updates. Seems a bit daft that it breaks things all the time. Can you not get Jaksta to check and turn it on every time it starts?

JMR doesn't break it or edit that services or any other services registry entries.


In all these years you are the first person I have heard of that has this service switched off.  JMR (if running normally) won't have permission to start any services (as it doesn't need to do that).


Will definitely put a check in to prompt if that error is received with a bit more info to say that service might be down.


Hey guys.


I don't want to hijack the thread but add my observations.

I rarely use "Auto". Normally I add a stream by pasteing it to Jaksta's own url bar. Because of this I didn't notice I get the same error as GregC when using auto.

1. I start Windows (complete reboot).
2. I start Jaksta.
3. I click on Auto.
That's the moment I get the error. And when I then click Auto again there's no error but Jaksta also doesn't discover streams.

However, when I now close Jaksta and re-open it and then click Auto again there is no error and the stream detection works perfect.

So basicly the only time the error occurs is the first time after a reboot and the first time clicking on Auto in Jaksta. This is only a small annoyance and I would not even have reported it till I saw this thread.

1. I use Chrome instead of Firefox.
2. My WinHTTP Web Proxy Auto-Discovery Service is set to manual and is running.
3. I can edit the proxy config in Windows/IE.
4. I have already re-installed Jaksta (to test something else). So that's not the problem either.

Long story short, I do NOT think this is a problem Jaksta causes. I do think that one of the Windows Updates during the last weeks caused this. Just like recently Windows Defender prevents changes to the HOSTS file I bet some Windows Update now interferes with Proxy changes.

Unfortunately I can't narrow it down since I rarely use "Auto", as I already wrote.

Good luck to you guys.

This doesn't happen on the several test machines I have access to so not sure if its a windows update thing.


@andreas - can you provide debugs logs.  Reboot and turn debug logs on,  turn AUTO on - get the error - collect logs and post here, so I can see what is happening on your machine.




I was finally getting to stay with relatives at the weekend and I checked their Windows 10 setup.


They too had the  WinHTTP Web Proxy Auto-Discovery Service disabled.


They don't use Jaksta so had not noticed it. It seems some Windows update has turned it off for some reason. They had Windows Home and I have Pro.

I will keep an eye on it and report.

Login or Signup to post a comment