Login  Sign up

Jaksta Media Recorder 7 DVR stuck on "Loading Browser"

Everything was working fine until my Windows 10 laptop did an auto-update last night.

Ever since then, the DVR Browser get stuck on "Loading Browser..."

Same issue no matter what DVR shortcut buttons (Hulu, Netflix, Amazon,etc.) I try.  

Again, this was all working fine prior to the Win10 update.  Might be worth noting that after restarting post-update, got a message that Jaksta had shut down improperly so setting would b reset.

Tried a fix from another post (Control Panel -> Network and Internet -> Internet Options -> Connections -> LAN settings -> check "Use a proxy server...") to no avail.

Any suggestions would be greatly appreciated.

After trying to uninstall, reboot and then reinstall if the issue still persists then please provide debug logs as per 


Tried uninstall, reboot, reinstall to no avail.  

Recorded debug logs trying to launch Jaksta Media Recorder 7 DVR browser for Hulu, Prime Video, and Netflix.  Log attached.

Please advise.


Try deleting the folder C:\Users\<your user name>\AppData\Local\Jaksta Media Recorder 7\ChromeDvr and then restart JMR.

Deleted the folder as you suggested then restarted JMR.  Still running into the same issue - DVR window opens, but just get "Loading Browswer ..." regardless of which DVR button (Netflix, Prime Video, Hulu, etc.) I try.

From your last logs jbwdp.exe is starting and immediately exiting.   Is your AV blocking it or something else stopping it from starting?

Perhaps your Windows Event logs might show something.

Login or Signup to post a comment