Login  Sign up

Soundflower won't install

Soundflower won't install on my new Mac Mini M1 so I can't use Screen Recorder.

Hi Andy

We do have a solution for this. It's a bit of a process, but it shouldn't be too technical and we will look to implement its setup in our own installers sometime in the near future.

The problem is that Soundflower is no longer able to be installed in Big Sur as it is not supported by the developer (we are not the developer).

An alternate open-source process called BlackHole can be used in its place to enable audio recording. For now it needs to be installed and configured manually.

BlackHole installation and setup:

  1. Go to: https://existential.audio/blackhole/
  2. Enter in details and press the 'Subscribe for Free Mac Download' button
  3. Wait for email to be received (see notes regarding email on the page)
  4. Use the code in the email to access the installer download page
  5. Click the 'BlackHole 2ch v0.2.8' download button
  6. Run the downloaded installer and go through the installation process
  7. Run: Audio MIDI Setup
  8. Press the + button in the bottom-left and select 'Create Multi-Output Device'
    • This will create a new Multi-Output Device which will appear in the device list down the side, and will be automatically selected
  9. Tick 'BlackHole 2ch' ON in the 'Use' column to the left
    • Built-in Output should already be ticked ON
  10. Use the 'Master Device:' selector to toggle between the two devices and ensure that both have the 'Sample Rate:' selector set to '44.1kHz' - manually change if needed

Jaksta Screen Recorder configuration and recording:
  1. Play a video that includes audio
  2. Run: Jaksta Screen Recorder
  3. Open (starting from the top-left menu): Jaksta Screen Recorder > Preferences > Advanced
  4. Set the 'Select audio device when recording' selector to 'BlackHole 2ch'
  5. Close the Preferences window and prepare a recording using any of the modes, but do not start the recording
    • If using Region or Full Screen mode ensure that the 'Audio' selector is set to 'BlackHole 2ch' - manually change if needed
  6. Run: System Preferences
  7. Open: Sound > Output
  8. Select 'Multi-Output Device' from the list
    • If there are more than one Multi-Output Devices then it should be the latest one (highest numbered)
  9. Start the recording in Jaksta Screen Recorder
    • Audio should be present from the speakers during recording
  10. Stop the recording after a reasonable amount of time and test the recorded file
    • The recorded file should contain audio and be in sync etc.
  11. Once all recording is completed and Jaksta Screen Recorder is no longer in use (closed), revert the selected device to 'Internal Speakers' (or any other preferred speakers/output device) in the System Preferences > Sound > Output list

If making several recordings in a row then repeat Steps 9-10 as many times as needed before finishing (Step 11).

This manual configuration and recording process (minus Steps 3 and 4) will need to be repeated each time the application is opened to start a recording.

Also, if you are wanting to use the Audio Capture mode in Jaksta Music Recorder then similar steps will need to be taken. Let me know if you need any guidance with that if you can't work it out easily enough.



Jaksta Support

I have followed the above procedure (several times) but I am not hearing the audio during recording and there is no audio when I play the recording back.

I have followed the procedure (several times) but there is no audio through the speakers during screen recording and there is no audio on the recording.


Login or Signup to post a comment