Welcome
Login  Sign up

JMR crashing

After the latest engine updates, JMR went from 100% rock solid to crashing regularly!  How can I roll back to the previous engine version?  This one is unstable!


Running JMR 7 (7.0.24.0)


You cant.


Please provide debug logs as per https://www.jaksta.com/support/windows/technical/jaksta-media-recorder/how-to-generate-debug-logs-6000009063 showing the crash or describe it it more detail.



The "additional description" would be that ... before the latest engine update I ran JMR, and it kept running all the time without ever disappearing.  Since the latest engine update I find that JMR is gone ... no longer running ...  That's all that I know.  It would never disappear before, and now it disappears, stops running.

Highly unlikely that is anything to do with the extraction engine.  


Do you have a scheduled recording that has "At Complete" set to "Quit application"?


Can you attach the debug logs please.

Do you have a scheduled recording that has "At Complete" set to "Quit application"?


No.  I didn't even realize that one could do that!  I'll have to generate the logs.  For now I've created a task with auto-restart, but I can see several videos that have completed with errors (meaning, that JMR aborted in the middle of capturing them).  That never used to happen before.  It may not be causation, but the observable correlation is that this never happened before and is happening since the latest engine update.

The extraction engine is only used by the monitor feature and when you enter a url in the "Enter (or Drag and Drop) the URL of a video page to download" text box.


This method only supports around 100 poplular sites that can be captured by extracting stream urls from the site.


AUTO mode, DVR and Audio Recording do not use the extraction engine.


Dont forget sites change all the time, and when they do new extraction engine updates are required for the monitor feature to keep working. 


 In most cases auto mode will work (unless a new protocol is released that JMR doesnt support).  And there is always DVR and Audio Recording modes for those sites that are not possible to capture from via direct download. 


If you have sites failing then please let me know which site and I can look at supporting what has changed.  Debug logs are good as well.

Thanks.  I only use monitor mode with CB.

Hello,

 @CSR can we somewhere see what are the like 100 sites supported by monitoring, is there a published list or somewhere in the options? most i monitor are already supported, but a list would be nice also to explore a bit :)


I just uncovered a bit more detail of what's going on ... only to increase the mystery.  What's actually happening is that the UI is dying, but the jmrp.exe process is still running!  This explains why my Task Scheduler entry to auto-restart wasn't doing anything.  So, UI is gone, there is no monitoring / recording, but the jmrp.exe process remains running.  The logs aren't very useful;  they don't show any errors or abnormal processing.  Any other ideas?

Is it in your system tray?  Ie near where the clock is?


You may have switched on Settings > Personalization > Minimize to Windows System Tray

It's precisely because it is NOT in the System Tray (as it normally is in my case) how I first became aware of the issue.  When my process monitor did not report a restart then I realized that my assumption that the process was dying was incorrect.  Instead, the jmrp.exe process was actually running and never stopped running.  However, not only did it disappear from the system tray (thus, I could not bring up its UI) but it wasn't monitoring and recording.  I know this because at the time that I realized this state there was a video playing that is normally recorded and wasn't recorded while in this state.


Before running under the process monitor I was running as a scheduled task with the standard output and error redirected to logfiles.  I know from that configuration that no output is generated to either during this state when jmrp.exe enters this state.

Also, the latest engine update has now started trigger antivirus alerts of suspicious connections.  I'm tracking down what it is.  I'm going to have to disable updates.  The product used to be rock-solid stable, and it's now just getting worse with each update.

An over zealous anti virus configuration that results in lots of false positives can cause issues for lots of products.  If your issue was systemic then this forum and Applian would be over run with comments.  


please provide debug logs. Ensure debug on start is on and restart Jaksta and use as normal until you experience the issue. Also please provide msinfo32 export after the issue appears. How to do that is in the howto debug logs page at top of forum

Unfortunately, the logs are not deidentified.  I tried doing it, but it would take me forever.  Sorry.


FYI:


  • I completely uninstalled (including removing all configuration from the uninstaller, and I also have an installer monitor which removed registry keys and files left behind by the uninstaller), and re-installed using the original installer.  JMR restarted and applied all updates.  Same problem / behavior.
  • I repeated but this time removed Internet connectivity, disabled automatic updates, and filtered connections to the jaksta.com domain (which JMR complained about not being able to reach in one of my many tests).  No issues at all.  Stable as was originally.
  • I wanted to be sure, so I repeated the whole process again.  Repeatable.


If it's AV-related, then my guess is that less sensitive AV practices / configurations / products can't detect the issue.  I want to be clear (and avoid misunderstanding) that the AV doesn't report a specific threat - it reports a "suspicious connection attempt."  I've asked the AV vendor to help me identify the nature of the concern.


What does seem certain is that it's something in the engine updates, which aligns with my original observation.

Login or Signup to post a comment