Login  Sign up

Anyone else now unable to use Jaksta DVR with Netflix? (and Amazon Prime, and Xfinity Stream)

Xfinity Stream no longer works for me on Jaksta DVR.

Now Netflix is not working with Jaksta DVR (Win 10 v7.0.24.0 - latest)

I get this Netflix error screen that my browser (Jaksta DVR Browser) is no longer supported.

So I updated Chrome (91) and Edge (91) and tried using WhatIsMyBrowser.com and pasting the urls into the "User Agent Override" in Settings.

THEN when I try to watch Netflix in Jaksta DVR I get a Silverlight error.


Similar issue with Amazon Prime Video where I see a message that my browser is out of date and will not work with Prime Video after May 31.  It kept working until this week.

So in one week, all of the following stopped working with Jaksta DVR:

  • Netflix
  • Xfinity Stream
  • Amazon Prime Video
There may be others, but those are the one's I've noticed.  Jaksta DVR started failing on each of these on different days,

So as of right now, Jaskta is basically useless to me.



Over the last week a bunch of DVR only sites have dropped support for Chrome 74, (which is the version we distribute to allow DVR recording to happen).  

This was the last version that allowed code injection.  New versions of Chrome don't allow the DVR code to be injected into them.

I am currently looking at a different way to do DVR. 

Has there been any progress on this? This has reduced the usefulness of the product significantly.

Having the exact same issue. I can't seem to view Netflix anymore.

DVR is an issue at the moment.  Im working on it.

My DVR was working fine until I upgraded my acer laptop to windows 10 from 8.1 and now the browser will play the video but as soon as I hit record Jaksta sends a message saying that the file could not be found. Happens on all major streaming services. Unless there is a work around it looks like Jaksta is dead. What a shame.

Not dead at all.  DVR is only one component of JMR.  I'm still working on working around all the new features of the latest browsers that netflix et all require so that we can DVR.  Have been making some good progress.

Thanks for the information. As a user it is very frustrating to spend hours trying to resolve issues by changing settings to see if it will solve the problem when there is a known issue that the developers are working on. Perhaps you could copy me and others who have experienced the problem into an email to inform us that the issue has been resolved or will this manifest itself as an upgrade in due course that will automatically occur on start up?

Since my post I have disabled the security boot in the bios and redirected the audio settings to alternative rather than"what you hear". I have also done my original search on Microsoft edge and pasted the url and then opened the Netflix or Apple TV tab in the DVR menu. It works sort of, but there are still issues . The DVR'ed program stops before finishing ( I have disabled the split on silence tab) and also I am getting an annoying warning in the audio track saying this is a trial version every few minutes. This is despite having an activated copy of Jaksta. I have tried deleting the program and going for a fresh install and activation on several occasions but the last problem has not cleared. I am only letting you know my experience so that as a developer you are aware of the glitches I have experienced. You may well know these but I have been unable to find a thread in the FAQ section. My comment that Jaksta is dead  for me at present because the DVR part of the program is the only part of it I use so that I can take streamed series away to a holiday home where I have no internet. There are no other comparable programs available to do just this so I hope these issues can be resolved.

Further trial and error again today. The activation problem has been solved with a second deletion of program, reboot ,reinstall and activation. The disabling of the security booting in the Bios gives a good audio recording by using the "alternative" setting for audio. The work-around for the url problem with the embedded chrome browser ,seems at present, to be to search for it in Microsoft Edge and pasting it into the url line after using the embedded links to find the same video. It's a bit of a fiddle but it works. I am sure the developers will find a more elegant way of doing it in due course. It may be that in time other browsers such as Edge and Firefox will include the same problems encountered with Chrome as they are upgraded and then it will be back to the drawing board !

Login or Signup to post a comment