Login  Sign up

tubi tv show wont download

url not supported...i tried auto method too..nothing

ive had no problem with other shows but not this one..."Family" tv show from 70's all episodes wont download

url - Watch Family S03:E01 - Acts of Love (Part One) Free TV | Tubi (tubitv.com)

i see there is a betas version but isnt it for MAC...what about windows 10 ?

I get the following with attempting to go to that link.

Content Unavailable

Sorry, this video is not currently available.

so is there a fix for this..what can i do ?

The link you have provided doesnt exist.

Yes..But if you use any browser other than from Jaksta app....all episodes play from that show..so if videos from that show play why can't you copy & paste then download in jaksta..

That screen shot is normal google chrome.  Please check the link you have provided or perhaps its not available in Australia which is where I am, but I didnt think Tubi was like that.

Provide debug logs if you can see and play a video at the link you have provided showing you trying to download it.  https://www.jaksta.com/support/windows/technical/jaksta-media-recorder/how-to-generate-debug-logs-6000009063

im in the us...yes i used a vpn once  and tried canada and that show wasnt available..but im using edge browser and all episodes play


Looks like you are using the show link - not the episode link.

Ie your using https://tubitv.com/tv-shows/599882?start=true,  try https://tubitv.com/tv-shows/599882/s03-e01-acts-of-love-part-one?start=true

and provide debug logs if it doesnt work.

ok..same thing happens on episode link


What about DRM ...Digital Rights Management...heard tubi is using this in browsers..heard that some shows use this..could this be the problem ??

Well you didn't get back to me but I think I found a work around so far its working sorry to say but it is not with your jaksta software.. What I think was causing the video not to play was DRM.. The work around is a little time consuming but I'm using a screen capture recorder software with Firefox browser...edge and Chrome browser gives you a black screen but Firefox browser doesn't
Login or Signup to post a comment