Login  Sign up

M1 Chip - Installation Fails / Won't Record

Used to love this product and renewed good money for it.

It stopped recording and working when I updated my MacBook Pro M1. Thought maybe it was my computer.

Couple months later I got a new MacBook Pro M1 Pro and now Jakasta will not even download - installation fails every single time.

GF has a non-M1, Jakasta works.

It's been months! 

Jakasta - will this ever be fixed or should we find a new product? Used to love this service, please update! 

same on my end - iMac 2017 - stopped working when trying youtube downloading and converting 

nou even no connection without mentioning "danger" - not secure site - and comments ?

Been a happy user of Jaksta since 1.1.1, purchased on 1/26/2011. Currently 2.2.5 works great with my 2013 MBP, running OS 10.14.6. Have a new 2021 M1 iMac, running OS 12.4. When I tried to install beta 3.0.0-316, I get "...can't be opened because Apple cannot check it for malicious software..." See attached screen capture. 

The version that works on my MBP, 2.2.5, does not install at all on the M1 iMac. 

Any suggestions? Thank you.

Hi all,

Apologies for the very delayed response.

We have a new beta available which should offer better performance on Monterey. You can download the beta here: https://download.shedworx.com/jaksta/beta/3.0.2_309/JakstaMediaRecorder.pkg

If you are not running Monterey then you are still welcome to try the beta, but please be aware that we have reports of varying success on earlier MacOS.

When you first attempt to run the installer you will receive a Mac OS notification saying that it can't be opened because it cannot be checked for malicious software. Click 'OK' and then go to System Preferences > Security & Privacy > General and click on 'Open Anyway' down the bottom. It will either run the installer or another similar notification as the first will appear and you just need to click 'Open' and then the installer will run.

Please be aware that it may still not work in Safari, but we have reports that it will work with other browsers.

If there are any connection problem in browsers then the next thing to do is check the certificate. You can check and amend the trust properties on the certificate by doing the following:
  1. Open Keychain Access and go to: System Keychains (left menu heading) > System (left menu item) > Certificates (top menu item)
  2. Double click the applian.com certificate to open the information
  3. Expand the 'Trust' section and set the "When using this certificate:" value to 'Always Trust'
If the certificate looks alright and/or the connection is still broken in your browser(s) then see the instructions on how to check your proxy settings here: https://support.jaksta.com/discussions/topics/6000063391

Please let me know if there are any issues at the end of all this.



Jaksta Support

Login or Signup to post a comment