Login  Sign up

Media Recorder for Mac just not working!

Hi, I cannot get this software to work anymore. Really annoying. I am running beta 3.0 although when I tried to install it I got an error message saying installation failed. When I use the software I cannot get it to download anything, either by starting the video in a browser (safari or chrome) or by pasting the URL into the search bar. I'm running OS 12.4 on an M1 Mac. I've also tried it on an intel MacBookPro running 12.4 but the same thing (doesn't) happen. Please help!!! Thanks, Anthony 

1 Comment

Hi Anthony,

Apologies for the very delayed response.

We have a new beta available which should offer better performance on Monterey. You can download the beta here: https://download.shedworx.com/jaksta/beta/3.0.2_309/JakstaMediaRecorder.pkg

If you are not running Monterey then you are still welcome to try the beta, but please be aware that we have reports of varying success on earlier MacOS.

When you first attempt to run the installer you will receive a Mac OS notification saying that it can't be opened because it cannot be checked for malicious software. Click 'OK' and then go to System Preferences > Security & Privacy > General and click on 'Open Anyway' down the bottom. It will either run the installer or another similar notification as the first will appear and you just need to click 'Open' and then the installer will run.

Please be aware that it may still not work in Safari, but we have reports that it will work with other browsers.

If there are any connection problem in browsers then the next thing to do is check the certificate. You can check and amend the trust properties on the certificate by doing the following:
  1. Open Keychain Access and go to: System Keychains (left menu heading) > System (left menu item) > Certificates (top menu item)
  2. Double click the applian.com certificate to open the information
  3. Expand the 'Trust' section and set the "When using this certificate:" value to 'Always Trust'
If the certificate looks alright and/or the connection is still broken in your browser(s) then see the instructions on how to check your proxy settings here: https://support.jaksta.com/discussions/topics/6000063391

Please let me know if there are any issues at the end of all this.



Jaksta Support

Login or Signup to post a comment