Login  Sign up

Downloading is unsuccessful, from Australian on-demand service, '7plus'

Hello team,

Am hoping you can help me please.

I wish to download from the Australian on-demand service, '7plus'.

Am using Jaksta Media Recorder version 2022.3.6.0, to do this.

Jaksta M R successfully offers the choice of streams to download from - then, after the download goes ahead, JMR says 'Connecting' - but a short while after says 'Complete (Errors)'. Nothing more actually happens. No actual download.

Could anyone advise me over this please?

Many thanks.


Streams are copy protected, so you need to use the DVR recording feature for JMR.


Thanks for your reply, CRS.

Had already tried the DVR method, but that didn't work either!

Have tried again - but it's still unsuccessful.

This help page may need amending?: https://www.jaksta.com/how-to-guides/7plus

Thought I'd used JMR for other sites (streams) that I thought were copy-protected, and they seem to download well.

If any kind of 'fix' is possible, I had hoped it would be the download route - to avoid possible buffering, etc.


JMR will not directly download copy protected content.  To make software that does is illegal.

DVR works fine here as per the image I showed.

Please provide debug logs as per https://www.jaksta.com/support/windows/technical/jaksta-media-recorder/how-to-generate-debug-logs-6000009063 so I can work out what is wrong on your machine.

Thanks for your reply and for offer of debug help.

Obviously it's just my machine. Sorry.

Have done a PC system restore and re-installed JMR (2022.3.6.0).

It has worked briefly - but it's still very temperamental.

But I realise - now - that this is not necessarily a Jaksta problem.

Apologies If I've wasted your time.

I'm going to 'mark as solved' (thank you), and if I do get in to more probs, trust it's acceptable to start another thread, please.

All the best,


Login or Signup to post a comment